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Part A

Guidelines For Climate Risk Assessment

1. Introduction

Climate change presents a significant challenge to society, affecting both individual and
collective decision-making (Adger et al., 2018). It interconnects human, social, and
institutional systems with dynamic environmental processes, leading to cascading risks across
ecosystems and economies. The Sixth Assessment Report (2021) by the Intergovernmental
Panel on Climate Change (IPCC AR6) states that recent climatic changes are unprecedented,
with global warming projected to increase by 1°C to 1.5°C under low greenhouse gas
emission scenarios and up to 5.7°C under very high scenarios. This rise is expected to
amplify extreme weather events, such as heatwaves and droughts, with severe implications
for flooding and ecosystem stability. Ecosystem services vital for agriculture, forestry, and
fisheries are declining, highlighting the inadequacy of current adaptation measures, especially
for vulnerable populations. The IPCC AR6-WG-2 (2022) warns that a 1.5°C rise by 2040
will worsen biodiversity loss and food security, disproportionately affecting vulnerable
regions.

While adaptation is crucial, progress is hindered by limited resources, low citizen
engagement, and financing issues. Although ecosystem-based adaptation provides
co-benefits, its effectiveness diminishes with rising temperatures. Integrated approaches to
address interconnected risks are essential, and overcoming existing barriers is vital for
mitigating climate change impacts and advancing sustainable solutions.

2. Risks of Climate Change

Climate change poses growing challenges as its impacts become increasingly complex. The
likelihood of multiple climatic hazards occurring simultaneously is rising, often interacting
with non-climatic risks to amplify overall risk. Managing these risks requires a
comprehensive strategy that addresses the interplay between climatic and non-climatic factors
to ensure community well-being and system sustainability. According to IPCC WG-2 (2022),
near-term risks are shaped more by vulnerability, exposure, and socioeconomic factors than
by variations in climate hazards across emission scenarios. Regions with high vulnerability,
non-climate stressors, or proximity to thermal thresholds face heightened risks. Assessing
risk is further complicated by the dynamic interactions of spatial, temporal, and multiple risk
factors.

There are many different ways to define risk.

• Risk = probability x consequence

• Event risk: probability of occurrence of event associated with adverse outcomes

• Outcome risk: probability of occurrence of adverse outcome (linked to event risk and
mediated by sensitivity/vulnerability of exposed system)
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• Risk is associated with a "trigger" event or "hazard," and impacts mediated by characteristics
of the exposed system

• Risk = f (hazard, vulnerability)

However, the preeminent and widely embraced framework for comprehensively defining risk is the
one articulated by the IPCC in 2014. This framework encapsulates a holistic understanding of risk,
acknowledging the interplay between hazards and vulnerabilities in shaping adverse outcomes.

2.1 IPCC Risk Definition and Framework

The risk definition and framework presented in this manual is adopted from the AR5 framework of
the IPCC (2014), which is also adopted in IPCC-AR6 (IPCC, 2022), and is presented in Figure A-1.
As defined by IPCC, risk in the context of climate change results from dynamic interactions of
climate-related hazards with exposure and vulnerability of the affected human or ecological system.
Hazard, exposure, and vulnerability may each be subject to uncertainty in terms of magnitude and
likelihood of occurrence, and each may change over time and space due to socioeconomic
development, adaptation responses and human decisions.

Figure A-1: IPCC Risk Framework (IPCC, 2014)
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Risk (R)

The potential for consequences where something of value is at stake and where the
outcome is uncertain, recognizing the diversity of values. Risk is often represented as
probability of occurrence of hazardous events or trends multiplied by the impacts if
these events or trends occur. Risk results from the interaction of vulnerability,
exposure, and hazard.

Hazard (H)

The potential occurrence of a natural or human-induced physical event or trend or
physical impact that may cause loss of life, injury, or other health impacts, as well as
damage and loss to property, infrastructure, livelihoods, service provision,
ecosystems, and environmental resources. In this report, the term hazard usually
refers to climate-related physical events such as droughts, floods, hurricanes, etc.

Exposure (E)
The presence of people, livelihoods, species or ecosystems, environmental functions,
services, and resources, infrastructure, or economic, social, or cultural assets in places
and settings that could be adversely affected.

Vulnerability (V)
The propensity or predisposition to be adversely affected. Vulnerability encompasses
a variety of concepts and elements including sensitivity or susceptibility to harm and
lack of capacity to cope and adapt.

The assessment of potential risks to an ecosystem, infrastructure, cropping systems, or community
hinges on the dynamic interplay of various factors. These include the nature and intensity of the
hazard, the magnitude of exposure experienced by communities and ecosystems, and the susceptibility
and adaptability of these entities—their sensitivity and adaptive capacity—to specific climate hazards.
Risk can be assessed for a single hazard or a set of hazards within a given region by accounting for
their frequency and intensity based on historical trends.

2.1.1 Hazard-specific Risk Assessment

A climate hazard refers to a climate extreme or trend with the potential to cause adverse consequences
for specific elements within an affected system (Reisinger et al., 2020). Various hazards emerge from
climate extremes, whether related to temperature (extreme heat or cold) or precipitation (rainfall or
snow). These encompass heat, cold, wet and dry conditions, spanning both mean and extreme
variations, alongside cryosphere hazards (snow cover, ice extent, permafrost) and oceanic hazards
(marine heatwaves). Some hazards manifest gradually or are slow-onset events (e.g., drought and
desertification), while others are abrupt or rapid onset events (e.g., cyclones and floods).

Risk assessment can be conducted for a singular hazard or multiple hazards, falling into various
categories or types. A single climatic hazard, such as a flood, has the potential to inflict significant
loss and damage to human life and assets. In some instances, the simultaneous occurrence of multiple
hazards can escalate risks and impacts. For instance, heat stress followed by drought may lead to the
occurrence of forest fires.

2.2 Why Assess Risks Associated with Climate Change?

Risk assessments offer a systematic approach to understanding climate change risks, enabling the
prioritization of adaptation policies and efficient management strategies. Consequently, climate risk
assessment becomes the cornerstone of effective climate risk management. This entails analysing the
repercussions, probabilities, and responses to the impacts of climate change, all while considering
available options within prevailing constraints. By identifying risks and assessing the extent of their
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impact on individuals, assets, value chains, infrastructure, settlements, and ecosystems, climate risk
assessments provide decision-makers with actionable insights.

Vulnerability and risk assessments are critical first steps in addressing climate change, guiding the
development of adaptation or resilience policies, programmes, and projects. While many initiatives
currently focus on vulnerability assessment, there is a growing need to advance beyond
vulnerability-centric approaches and transition towards a more inclusive evaluation that incorporates
risk in the development and execution of adaptation and resilience programs and projects. Integrating
risk assessments into adaptation efforts offers a more holistic understanding of climate challenges and
improves management outcomes. As experience in this field grows, tools such as risk indices and
maps are increasingly recognized for their value in shaping and enhancing adaptation initiatives.

Risk assessment is necessary for multiple reasons and will help:

● Identify and Prioritize Risks: Assess and rank regions, districts, cropping systems, and
communities susceptible to climate change-related damages and losses.

● Inform Adaptation Planning: Communicate to decision-makers the need to address not only
hazards but also the drivers of exposure and vulnerability in adaptation planning.

● Anticipate Changing Risks: Understand how risks, based on historical or recent climate trends
will evolve or intensify under different climate change scenarios.

● Predict High-Risk Areas: Determine which districts, regions, and communities will face
elevated risks or increased impacts in the coming decades due to climate change.

● Quantify Risk Components: Assess and quantify the extent of risk attributed to hazards,
exposure, and vulnerability individually, as well as their combined impact (Hazard + Exposure +
Vulnerability). Also, highlight that exposure and vulnerability are significant contributors to loss
and damage from climate change, sometimes outweighing the impact of hazards. It also helps
provide a realistic depiction of climate change risks compared to vulnerability assessments, which
usually is estimated independent of climate hazards.

● Identify Key Risk Drivers: Determine the primary drivers of risk to communities and
ecosystems, whether they stem from hazards, exposure, vulnerability, or a combination, and
identify key indicators contributing most to overall risk.

● Project Identification for Funding: Identify tangible adaptation projects suitable for funding
from donors, bankers, and other agencies, integrating considerations of climatic hazards,
exposure, and vulnerability.

Mapping climate change risks using a common framework is integral for understanding the entry
point of interventions. This approach aids in identifying the key risk drivers—whether they stem from
hazards, exposure, or vulnerability—providing a comprehensive understanding of the challenges at
hand. By delineating the scope for adaptation and highlighting potential maladaptation pitfalls to be
avoided, this exercise becomes a guiding tool for states. Moreover, it serves as a practical resource for
optimizing the utilization of adaptation funds over a specified time horizon. For instance, addressing
vulnerability may be feasible in the short to medium term, while mitigating exposure requires a more
prolonged commitment and substantial financial investment. Armed with this information, states are
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Risk (R)
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empowered to prioritize interventions, ensuring a strategic and efficient allocation of resources to
tackle the most pressing climate risks.

In the current guidelines, the focus is on two predominant hazards in India —droughts and floods. As
a slow-onset disaster, drought is primarily characterised by a lack of precipitation for prolonged
periods of time. However, drought is a relative term, and may be defined in multiple ways. The IPCC
defines drought as 'a period of abnormally dry weather long enough to cause a serious hydrological
imbalance' (IPCC, 2019). Contrary to droughts, floods result from excessive rainfall. The IPCC
defines floods as, 'the overflowing of the normal confines of a stream or other bodies of water, or the
accumulation of water over areas that are not normally submerged' (IPCC, 2019). The different
definitions of droughts and floods, and their characterisation in the context of this risk assessment
guideline are discussed in Section 3.1.1.

Why Focus on Droughts and Floods?

Various regions, including states and districts, face distinct exposure to a range of hazards. Coastal areas
are exposed to storms, cyclones and hurricanes, while mountainous regions are exposed to floods and
landslides. Tropical or low-latitude regions are particularly prone to severe heat stress, although temperate
and high latitude areas may also experience significant challenges in this regard.

Droughts and floods, on the other hand, are prevalent across a majority of countries, states, districts or
regions. In India, according to IMD, 87% of districts are drought-prone, and 30% are at risk of floods.
Additionally, 14% of districts are vulnerable to cyclones, and 13% are exposed to heat waves. Many
districts are exposed to both drought and flood events, and during certain years, a district may experience
drought followed by floods within the same year.

Thus, the focus of the current assessment is on droughts and floods, due to their significant
socioeconomic impacts in India, but the methods and guidelines can be applied to assess risks from
other hazards as well.

3. Assessing Hazard, Exposure, Vulnerability, and Development of the Risk Index

Risk is a result of interaction among the three components namely, hazard, exposure and vulnerability
as described in the IPCC-Risk Framework (Figure A-1). In the subsequent subsections, we discuss
assessment of each of these components—Hazard, Exposure and Vulnerability. In Table A-1, a
summary of steps in risk assessment or risk index development is presented.

Table A-1: Detailed Steps for Climate Risk Assessment

Step 1 Define the objectives of risk assessment: Current Risk
assessment

1. Assist in adaptation planning
2. Prioritising adaptation investment

Step 2 Define the type of risks to be assessed:
Hazard-specific risk assessment under current climate

1. Drought hazard
2. Flood hazard
3. Others

Step 3
Define the region / scale for risk assessment and
define the boundary for risk assessment; District, State
and Country

1. State & district
2. Cropping systems

Step 4 Define the risk framework
Hazard, Exposure, Vulnerability based framework IPCC, 2014 Risk Framework
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Step 5 HAZARD INDEX ASSESSMENT

Step 5.1 Hazards for risk assessment under historical climate
data

1. Drought hazard
2. Flood hazard

Step 5.2
Obtains historical climate data for the selected hazard:
Daily / Monthly Rainfall data in mm at the district
level or 0.25 x 0.25-degree gridded data.

1. Drought data
2. Flood data
3. Period: 30 to 50 years

Step 5.3
Select a method or equation to estimate the selected
Hazard Index, Drought, and Flood hazards under
current climate scenario

SPI = Standard Precipitation Index
(Based on WMO)
Geographic Information System (GIS)
based flood susceptibility mapping using
multi-criteria decision analysis (MCDA)
techniques.

Step 5.4 Estimate the Drought Hazard Index and Flood Hazard
Index

Drought / Wet events
- Low / Moderate / Severe
- How many years out of past 30 years
- How many years out of projected 30
years
Flooded area:
- Very low/ Low/ Medium/ High / Very
high
- How many years out of past 30 years
- How many years out of projected 30
years

Step 6 EXPOSURE INDEX ASSESSMENT Ex; at District scale

Step 6.1 Select Hazard-specific exposure indicators and collect
data for selected indicators under current climate.

- Select indicators for selected scale
-Estimate current value of exposure
indicators

Step 6.2
Normalize, give equal weights and estimate the
Exposure Index at the scale selected under historical
climate period

- Estimate Exposure Index

Step 7 VULNERABILITY INDEX ASSESSMENT

Step 7.1
Select hazard-specific indicators for vulnerability
assessment at the scale selected and compile data for
the indicators under historical climate period.

- District scale
- Current value of vulnerability indicators

Step 7.2
Normalize, give equal weights, and estimate the
vulnerability Index at the scale for historical climate
period.

Step 8 RISK INDEX DEVELOPMENT

Step 8.1

Estimate Risk Index using the equation:
𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅 𝑅 𝑅 3 𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻

Where, H is Hazard, V is Vulnerability, and E is
Exposure

Ex. At district/state scale

Step 8.2 Rank the districts / blocks / communities; based on the
risk index values

- High / Moderate / Low Risk
- Very high / High / Moderate / low / Very
low

Step 8.3 Identify key drivers of risk.
- Hazard indicator
- Exposure indicator
- Vulnerability indicator

Step 8.4 Prepare Risk maps and classify and rank districts using
a scale; High Risk – Moderate risk – low risk

- Hazard map, Exposure map,
- Vulnerability map, Risk map

3.1 Assessment of Climate Hazard

According to IPCC AR6, WG2 (2022), hazard is defined as "the potential occurrence of a natural or
human-induced physical event or trend that may cause loss of life, injury or other health impacts, as
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empowered to prioritize interventions, ensuring a strategic and efficient allocation of resources to
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Step 2 Define the type of risks to be assessed:
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1. Drought hazard
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According to IPCC AR6, WG2 (2022), hazard is defined as "the potential occurrence of a natural or
human-induced physical event or trend that may cause loss of life, injury or other health impacts, as
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well as damage and loss to property, infrastructure, livelihoods, service provision, ecosystems and
environmental resources."

3.1.1 Types of Hazards

Risks of climate change or the impacts of climate change are determined by the type, frequency, and
intensity or severity of the hazard.

Hazard could be classified as:

● Direct climatic hazard event: Events such as high intensity rainfall, deficit rainfall, high
temperatures, and cyclones could be considered as direct climatic hazards.

● Consequence of hazard events: Floods, droughts, coastal erosion, landslides, heat stress, etc.
are direct consequences of climatic events. These consequences lead to loss of human and
animal life, damage to property, assets, infrastructure, crops, etc.

Climate hazards could also be classified as:

• Changes in variability and extremes

o Rainfall variability, seasonality - droughts

o Changes in peak precipitation intensity (flood risk)

o Changes in storm activity/behaviour/geographic distribution

o Heat waves, wildfires, etc.

• Long-term changes/trends in average conditions

o Warmer, wetter, drier, more saline groundwater, etc.

o Shifts in climatic zones, ecological/species ranges.

• Abrupt/singular changes

o Monsoon shifts

o Landscape & ecosystem transitions

o Glacial lake outbursts, etc.

3.1.2 Intensity and Frequency of Hazards

Both climatic hazard and consequential (or cascading) hazards such as drought or flood can have
various levels of severity or intensity such as i) Mild drought/flood, ii) Moderate drought/flood, iii)
Severe drought/flood.

Similarly, they may have different frequencies or number of events. For example, the frequency of
droughts or floods represents the number of observed severe drought/flood seasons or events during a
specific time period, say past 30 or 50 years. Likewise, there could be a number of Category 1 to
Category-5 storm/cyclone events per year or over 30 or 50 years.
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3.1.3 Definition of Drought and Flood Hazard

Numerous definitions of drought and flood can be found in literature. This section presents a few
different definitions for each hazard and offers a rationale for choosing a specific definition in the
context of this study.

3.1.3.1 Drought

The IPCC defines drought as a period of abnormally dry weather long enough to cause a serious
hydrological imbalance' (IPCC, 2019). However, they acknowledge that drought is a relative term,
and discussions around it, particularly in terms of precipitation deficit, must refer to the
precipitation-related activity that is impacted. For example:

● Meteorological drought: A period with abnormal precipitation deficit.

● Agricultural drought: Shortage of precipitation during the growing season that adversely affects
crop production and ecosystem function, primarily due to soil moisture stress.

● Hydrological drought: A deficiency in precipitation with consequences for runoff and
percolation, predominantly influencing water supply and resulting in hydrological drought.
Alterations in soil moisture and groundwater storage are further influenced by heightened actual
evapotranspiration, compounded by decreased precipitation.

The IMD (Indian Meteorological Department) declares a drought in a region when the rainfall falls
below 26% of its long-term normal. The severity of the drought is then categorized as either moderate
(deficiency between 26% and 50%) or severe (deficiency exceeding 50%).

Similar to the terminology used by the IPCC to categorize droughts, the IMD also distinguishes
between meteorological, agricultural, and hydrological droughts:

● Meteorological Drought: A meteorological drought is declared when the seasonal rainfall is less
than 75% of the long-term average for a particular area. The assessment of seasonal rainfall
typically includes the monsoon season spanning June, July, August, and September, as well as the
retreating monsoon occurring in October, November, and December.

● Agricultural Drought: An agricultural drought occurs when the soil moisture levels in the
topmost one meter of the soil are deficient for the specific crop being cultivated, resulting in
significantly reduced crop yields.

● Hydrological Drought: A hydrological drought is defined by the impact of dry spells on surface
or groundwater bodies. In this context, water resources fall short of meeting the demands of a
given water management system. In this guideline, the focus of drought hazard assessment is on
meteorological drought as defined by IMD. The only parameter required to gauge the probability
of occurrence of this type of drought hazard is rainfall.

3.1.3.2 Flood

The IPCC defines floods as 'the overflowing of the normal confines of a stream or other bodies of
water, or the accumulation of water over areas that are not normally submerged' (IPCC, 2019). Floods
can be caused by unusually heavy rain, for example, during storms and cyclones.

Flooding in a region is influenced not solely by the intensity and duration of rainfall but also by the
specific physical attributes of the ecosystem under consideration. These attributes encompass
topography, river morphology, the presence of glaciers, soil properties, characteristics of vegetation,
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degree of urbanization, and more. This intricate interplay gives rise to various types of floods,
including river floods, flash floods, urban floods, pluvial floods, sewer floods, coastal floods, and
glacial lake outburst floods (IPCC, 2012). Moreover, the geographical impact of floods is highly
diverse, ranging from localized inundation in urban areas to extensive flooding along major rivers
affecting numerous villages. The root causes of flooding can be exclusively weather-related, such as
intense precipitation, or anthropogenic, stemming from factors like unplanned urbanization. Often,
flooding is a result of a complex interweaving of both natural and human-induced factors.

Globally, individuals are increasingly experiencing unfamiliar precipitation and warming patterns,
including instances of extreme precipitation, prolonged dry spells, and intense heat events within a
single year. These phenomena contribute to various hazards, such as floods, landslides, droughts,
heatwaves, and even forest fires, resulting in the compounding impacts of these hazards. While
numerous climate-related hazards affect our country, droughts and floods stand out as the most
prevalent.

3.1.4 Methods for Quantifying Climate Hazards and Constructing the Hazard Index

A Hazard Index can be developed to assess historical climate trends over the past 30 to 50 years. The
methodology employed in developing the index varies depending on the specific climatic hazard
under consideration. Figure A2 provides a generic overview of the steps involved in assessing a
hazard for climate risk assessment, while Figures A3, A4, A5, and A6 shows the various illustrations
of hazard maps. However, the guidelines described in this manual focus on evaluating drought and
flood hazards; detailed descriptions of which are provided in Parts B and C of this manual,
respectively.

Figure A-2 Steps in hazard assessment
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Figure A-3:3-month SPI map.

(Source: WMO 2012)

Figure A-4:Multiple Climate Hazard Index Map of
Southeast Asia

(Source: International Development Research Center,
Economy and Environment Programme for Southeast Asia)

Figure A-5: Historical Multi-Hazards Map
(Source: CRIDA, 2021)

Figure A-6: Future Multi-Hazard Map
(Source: CRIDA, 2021)

3.1.4.1 Drought Hazard Assessment

Numerous methods exist for evaluating drought or flood hazards, with the World Meteorological
Organization (WMO) offering a range of approaches, methods, and equations for constructing drought
and flood indices (WMO, 2012). Among these, the Standard Precipitation Index (SPI), introduced by
Mckee in 1993, stands out as one of the most widely utilized methods and indices for assessing
drought conditions.

The Standardized Precipitation Index (SPI), as defined by Mckee et al. (1993), is based on the
probability of observed precipitation across various time scales. The likelihood of observation is
converted into an Index, with SPI initially designed to quantify precipitation deficits over multiple
time scales. The SPI calculation for any given location is based on a long-term precipitation record for
a specific period. WMO (2012) provides a user guide and software tool to facilitate the development
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degree of urbanization, and more. This intricate interplay gives rise to various types of floods,
including river floods, flash floods, urban floods, pluvial floods, sewer floods, coastal floods, and
glacial lake outburst floods (IPCC, 2012). Moreover, the geographical impact of floods is highly
diverse, ranging from localized inundation in urban areas to extensive flooding along major rivers
affecting numerous villages. The root causes of flooding can be exclusively weather-related, such as
intense precipitation, or anthropogenic, stemming from factors like unplanned urbanization. Often,
flooding is a result of a complex interweaving of both natural and human-induced factors.
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of hazard maps. However, the guidelines described in this manual focus on evaluating drought and
flood hazards; detailed descriptions of which are provided in Parts B and C of this manual,
respectively.

Figure A-2 Steps in hazard assessment
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of SPI for drought assessment. Table A-2 presents SPI as an index, reflecting different levels of
dryness and wetness severity.

Advantages of using SPI

● Widespread applicability: The SPI is a widely employed and straightforward tool for assessing
drought hazards.

● Accessible resources: Toolkits and software supporting SPI are readily available, facilitating its
implementation for a diverse range of users.

● Meteorological basis: SPI relies exclusively on meteorological parameters, particularly rainfall
data, which includes the measurement of rainfall intensity in millimeters per day.

● Simplicity in design: The simplicity of SPI's design enhances its usability and effectiveness in
drought hazard assessment.

● International comparisons: SPI enables comparisons across different regions and countries,
providing a standardized metric for evaluating drought risk on a global scale.

Table A-2: Classification of SPI values

Value Classification

2.0+ Extremely Wet

1.5 to 1.99 Severely Wet

1.0 to 1.49 Moderately Wet

-0.99 to 0.99 Near Normal

-1.0 to -1.49 Moderately Dry

-1.5 to -1.99 Severely Dry

-2 and less Extremely Dry

Source: SPI User Guide, WMO (2012)

The frequency or probability of occurrence of dry or wet events could be expressed as the number of
events of a given type and severity of hazard; an example is given in Table A-3.

Table A-3: Probability of occurrence of dry events

SPI Category No. of times in
100 years

The severity of the event

0 to -0.99 Mild Dryness/Drought 33 1 in 3 years

-1.00 to -0.49 Moderate Dryness/Drought 10 1 in 10 years

-1.5 to -1.99 Severe Dryness/Drought 5 1 in 20 years

<-2.0 Extreme Dryness/Drought 2.5 1 in 50 years

The SPI computation relies on historical precipitation data from a designated weather station, wherein
the precipitation accumulation over a specific time frame is juxtaposed with the corresponding period
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in the historical record of that location. Data needed to compute SPI for historical and future time
periods is given below:

Parameters Historical Resolution

Monthly Rainfall IMD gridded data (1970-2019) 0.25° x 0.25°

The index is calculated based on the mean and standard deviation of rainfall for a particular district. It
offers a scale as seen in Table A-2, which indicates the severity, as well as, the return period of
droughts depending on the value. The SPI index can be calculated for different time scales (3, 6, 12
and 24 months).

● SPI3 indicates the comparison of short to medium-term moisture conditions.

● SPI6 indicates trends in seasonal rainfall.

● SPI9 indicates inter-seasonal precipitation patterns over medium timescales and,

● SPI12-SPI24 indicates long-term precipitation patterns.

The SPI metrics enable the assessment of diverse potential impacts associated with meteorological
droughts. In the current hazard evaluation, SPI6 is specifically employed. The computed SPI6 values
are subsequently juxtaposed against standardized benchmarks.

For a comprehensive description of the methodology and detailed step-by-step guidance for
computing the Drought Hazard Index using SPI, refer to Part B of this manual.

3.1.4.2 Flood Hazard Assessment

Identification and delineation of areas prone to flooding in any given region or basin is the first step to
flood risk assessment and an important flood prevention tool (Lin et al., 2020). Multiple flood
modelling techniques exist, each serving a specific purpose in flood risk assessment, mitigation, and
management. Two of the most commonly adopted approaches for deriving flood risk maps are the
hydrologic-hydraulic modelling (HHM) and the Geographic Information System (GIS) based flood
susceptibility mapping using multi-criteria decision analysis (MCDA) techniques. Flood susceptibility
mapping (FSM) integrating GIS and MCDA is the process of assessing and mapping areas that are
prone to flooding and is a widely used, scientifically robust technique (Mahmoud and Gan, 2018a,
2018b; González-Arqueros, Mendoza, Bocco, and Castillo, 2018; Das, 2020; Dash and Sar, 2020;
Chen, 2022; Gupta and Dixit, 2022). It involves analysing multiple factors such as topography,
geography, geomorphology, rainfall patterns, and historical flood records to evaluate the vulnerability
of an area to flooding.

Rationale for FSM: The primary objective of FSM is to identify areas that are at high risk of flooding,
enabling better planning, land management, and disaster preparedness.

The FSM method can provide a rapid assessment of flood-prone areas, especially in locations with no
prior flood modelling information or have limited resources and data. This method can be applied to
any particular region and scale such as a district or state and is not restricted to hydrological
boundaries.

On the other hand, physical attribute-based flood modelling methods require high-quality data, such
as long-term rainfall patterns, river flow data, hydraulic properties of the area, etc. and employ
complex calculations (Mudashiru et al., 2022). These data intensive methods also require specialized
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in the historical record of that location. Data needed to compute SPI for historical and future time
periods is given below:
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Monthly Rainfall IMD gridded data (1970-2019) 0.25° x 0.25°

The index is calculated based on the mean and standard deviation of rainfall for a particular district. It
offers a scale as seen in Table A-2, which indicates the severity, as well as, the return period of
droughts depending on the value. The SPI index can be calculated for different time scales (3, 6, 12
and 24 months).

● SPI3 indicates the comparison of short to medium-term moisture conditions.

● SPI6 indicates trends in seasonal rainfall.

● SPI9 indicates inter-seasonal precipitation patterns over medium timescales and,

● SPI12-SPI24 indicates long-term precipitation patterns.

The SPI metrics enable the assessment of diverse potential impacts associated with meteorological
droughts. In the current hazard evaluation, SPI6 is specifically employed. The computed SPI6 values
are subsequently juxtaposed against standardized benchmarks.

For a comprehensive description of the methodology and detailed step-by-step guidance for
computing the Drought Hazard Index using SPI, refer to Part B of this manual.

3.1.4.2 Flood Hazard Assessment

Identification and delineation of areas prone to flooding in any given region or basin is the first step to
flood risk assessment and an important flood prevention tool (Lin et al., 2020). Multiple flood
modelling techniques exist, each serving a specific purpose in flood risk assessment, mitigation, and
management. Two of the most commonly adopted approaches for deriving flood risk maps are the
hydrologic-hydraulic modelling (HHM) and the Geographic Information System (GIS) based flood
susceptibility mapping using multi-criteria decision analysis (MCDA) techniques. Flood susceptibility
mapping (FSM) integrating GIS and MCDA is the process of assessing and mapping areas that are
prone to flooding and is a widely used, scientifically robust technique (Mahmoud and Gan, 2018a,
2018b; González-Arqueros, Mendoza, Bocco, and Castillo, 2018; Das, 2020; Dash and Sar, 2020;
Chen, 2022; Gupta and Dixit, 2022). It involves analysing multiple factors such as topography,
geography, geomorphology, rainfall patterns, and historical flood records to evaluate the vulnerability
of an area to flooding.

Rationale for FSM: The primary objective of FSM is to identify areas that are at high risk of flooding,
enabling better planning, land management, and disaster preparedness.

The FSM method can provide a rapid assessment of flood-prone areas, especially in locations with no
prior flood modelling information or have limited resources and data. This method can be applied to
any particular region and scale such as a district or state and is not restricted to hydrological
boundaries.

On the other hand, physical attribute-based flood modelling methods require high-quality data, such
as long-term rainfall patterns, river flow data, hydraulic properties of the area, etc. and employ
complex calculations (Mudashiru et al., 2022). These data intensive methods also require specialized
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software and significant computational resources, along with high technical expertise. In areas with
limited access to such resources, the FSM approach is therefore a relatively simpler technique that
does not require advanced computational skills, making it more accessible and practical for flood
hazard assessment.

Advantages of FSM

● Simple, yet reliable and rapid assessment of flood prone areas.

● Can be employed in both gauged and ungauged locations, with limited data availability and
resources and no prior flood modelling.

● Applicable to any particular region and scale and not restricted by hydrological boundaries.
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Broad steps for flood hazard assessment:

Figure A-7 Steps in flood hazard index assessment

Part C of the Manual provides a step-by-step procedure with examples for using the FSM
methodology for flood hazard assessment.

3.2 Assessment of Exposure

Not all hazards automatically translate into risks; it is the interaction of hazards with exposed systems
that gives rise to risks. Exposure does not necessarily equate to vulnerability; individuals or
communities can be exposed to a hazard but possess the means to mitigate risk effectively. For
instance, residing in a floodplain exposes one to flood hazards, but with appropriate modifications to
building structures and behaviours, vulnerability can be reduced.

The selection and quantification of exposure indicators are contingent upon the scale of hazard
assessment. Consequently, it is feasible to choose and quantify broad indicators at the district level
using secondary sources of information. These indicators may encompass sensitive areas such as
rainfed croplands and forest lands, as well as specific populations like rural communities or those
living below the poverty line.

The selection of an exposure indicator must align with the resolution of the chosen hazard to ensure
accurate risk assessment. For instance, if a hazard is determined at a 0.25° x 0.25° resolution, but
exposure indicators are specified at the district level, the hazard value will be uniform across all
districts. This uniformity may lead to inaccuracies, as different districts may exhibit varying exposure
indicators, implying a consistent hazard level across all, which could be misleading.
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Steps in Exposure Index Development

Figure A-8 Steps in exposure index assessment

Indicators to represent exposure to a hazard could be:

● Socioeconomic indicators: Percentage of rainfed farmers in the area, percentage of
households or number of people living in flood-prone areas, percentage of SC/ST or BPL
population, population density.

● Biophysical indicators: Area under rainfed crops, an area with a high slope gradient, and an
extent of area under low-lying conditions.

An illustrative Exposure Map is provided below (Figure A-9):

Figure A-9 Population exposed to Flood (Source: Rentschler, Salhab and Jafino, 2022)

3.3 Assessment of Vulnerability

Vulnerability, in this conceptualization, can be specific to certain hazards or encompass a broader
perspective. In the context of our current project, which aims to formulate a risk index related to
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floods and droughts, the emphasis is on developing a vulnerability index that is specific to the hazards
in question. This hazard-specific vulnerability index will provide a targeted assessment of the system's
susceptibility to the adverse impacts associated specifically with floods and droughts.

Steps in Vulnerability Index Development

Figure A-10 Steps in hazard-specific vulnerability assessment
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Illustration of the Vulnerability Map (Figure A-11 and Figure A-12) is provided below:

Figure A-11 Vulnerability map of
India (Source: CRIDA, 2021)

Figure A-12 Vulnerability category map of Assam
(Source: Climate Vulnerability Assessment for the Indian
Himalayan Region Using a Common Framework, 2018-19)

3.4 Development of Risk Index

Risk is the function of hazard, exposure, and vulnerability index values. The risk index could be
estimated by giving weights based on experience and knowledge. The risk index could be estimated
using the following equation:

𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅 𝑅 𝑅 3 𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻

Where H is Hazard, V is Vulnerability, and E is Exposure.

The use of geometric mean is the best way of calculating the average value of components when they
are in ratios. Further, unlike the arithmetic mean, geometric mean does not assume substitutability
between dimensions. Various important global indicators, such as the Human Development Index
(UNDP, 2021), are calculated based on exactly a similar method of normalization and taking
geometric mean)

Steps in Risk Index Development

1. Estimate the Index values for hazard, exposure, and vulnerability

2. Combine Hazard, Exposure, and Vulnerability into a single index

3. Estimate risk using the equation: Risk = ∛(H × V ×E )

4. Rank the state/districts/blocks using the Risk Index

5. Classify the risks into High/Moderate/Low for the scale selected, such as state/district/block

6. Prepare a risk map using the risk severity classes: High, Moderate, Low

7. Identify the key drivers of Risk: Hazard / Exposure / Vulnerability Indicators
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Examples of risk maps: Very few studies have developed risk indices or risk index-based maps that
are fully consistent with the IPCC-2014 risk framework. There are vulnerability maps, exposure maps,
and hazard maps. The combined implication of hazard, exposure, and vulnerability to climate change
risk is inadequately understood and rarely applied. Some examples are provided in Figures A-13 and
A-14:

Figure A-13 Climate change Risk Map

(Source: CRIDA, 2021)

Figure A-14 Drought Risk Map of the World

(Source: Aqueduct Project, WRI)

4. Risk Assessment for Adaptation Planning

All adaptation frameworks and toolkits systematically integrate considerations of vulnerability, risk,
or a combination of both throughout the various stages of developing adaptation strategies, projects,
or practices. An illustrative instance of such integration can be observed in Figure A-15, showcasing
an Adaptation Tool that explicitly incorporates "Vulnerability and Risk" as pivotal components within
its framework.

The incorporation of risk and vulnerability assessments within adaptation initiatives serves as a
valuable resource for developers of adaptation programmes or projects. The Adaptation Support Tool,
consisting of six sequential steps, places the assessment of climate change-related risk and
vulnerability as the second crucial step. This positioning underscores the significance of early
consideration of these factors in the adaptation process. By systematically evaluating risk and
vulnerability upfront, the tool lays the groundwork for identifying appropriate adaptation options.

Furthermore, the flexibility of conducting risk and vulnerability assessments is emphasized,
suggesting that such evaluations can occur not only at the project's initiation but also during the
monitoring and evaluation stages (Figure A -16). This dual approach enables a comprehensive
understanding of how the implementation of adaptation programs or projects influences the prevailing
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risk and vulnerability dynamics. It facilitates a continuous feedback loop, allowing for adjustments
and improvements based on the evolving context throughout the project life cycle.

Figure A-15 Risk assessment for adaptation
planning (Source: Climate-Adapt from European

Union,
https://climate-adapt.eea.europa.eu/#t-adapt)

Figure A-16 Steps to Resilience Framework

(Source: US Climate Resilience Framework)

5. Utility and Application of Risk Index

The utility and application of a Risk Index are multifaceted and play a crucial role in enhancing
climate resilience and adaptation planning. Some of the potential applications or utility of risk
assessment and index are as follows:

1. Help stakeholders to identify the critical hazards faced by the region, district, communities,
cropping systems, etc.

2. Help stakeholders to identify the most consequential and important risks faced by the districts,
communities, and ecosystems both under current climate scenarios and projected climate
change scenarios.

3. Help stakeholders to identify the risk hotspots of climate change in the context of selected
hazards.

4. Identify the critical indicators of hazard, exposure, and vulnerability based on their
contribution to the risk index and individual indices such as hazard, exposure, or vulnerability
index.

5. Prioritize the state/district/blocks/cropping systems for adaptation planning and funding
utilizing the risk index, the indicators used, and the major drivers of risk, hazard, exposure,
and vulnerability.

6. Enable adaptation project developers to convince the funding agencies of the rationale for
adaptation programs or projects, leading to the utilization of risk maps in adaptation planning
and development to enable development of focused and prioritized adaptation interventions.
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6. Challenges and Limitations of Risk Assessment

Vulnerability assessment is more popular and broadly used than risk assessment and mapping. There
are a large number of research publications, manuals, and toolkits on vulnerability assessment
compared to risk assessment. However, risk assessment is more useful than vulnerability since it
incorporates climate hazards, which provide information on the most vulnerable regions for a specific
hazard. Nevertheless, there are many challenges and limitations in applying risk assessment tools:

Challenges in Risk Assessment

● Selection of hazard: Whether to select a single hazard or a combination of hazards.

● Definitions of drought/flood: there are multiple definitions of flood and drought.

● Data: Obtaining historical data for hazards, such as daily rainfall or temperature, at the scale
required and analysis is a challenge for many.

● Climate change modelling and projections: What scale, what period, which scenarios, and which
models should be selected? Further, the capacity to access and utilize climate change model
projections in developing hazard indices could be a limitation.

● Defining the hazard thresholds for different levels of intensity or severity of hazard could vary
from region to region.

● There are multiple equations to estimate the hazard and its severity and frequency.

● Selection of indicators for exposure and vulnerability and obtaining data for these indicators.

● Very often, there could be overlaps between indicators used for vulnerability and exposure.

● Giving appropriate weights to the indicators of exposure and vulnerability. Further, giving weights
to hazard index, exposure index, and vulnerability index could be challenging.

● Technical capacity is required to develop a hazard index and risk index.

● Interpretation and utilization of the risk indices and maps.
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hazard. Nevertheless, there are many challenges and limitations in applying risk assessment tools:

Challenges in Risk Assessment

● Selection of hazard: Whether to select a single hazard or a combination of hazards.

● Definitions of drought/flood: there are multiple definitions of flood and drought.

● Data: Obtaining historical data for hazards, such as daily rainfall or temperature, at the scale
required and analysis is a challenge for many.

● Climate change modelling and projections: What scale, what period, which scenarios, and which
models should be selected? Further, the capacity to access and utilize climate change model
projections in developing hazard indices could be a limitation.

● Defining the hazard thresholds for different levels of intensity or severity of hazard could vary
from region to region.

● There are multiple equations to estimate the hazard and its severity and frequency.

● Selection of indicators for exposure and vulnerability and obtaining data for these indicators.

● Very often, there could be overlaps between indicators used for vulnerability and exposure.

● Giving appropriate weights to the indicators of exposure and vulnerability. Further, giving weights
to hazard index, exposure index, and vulnerability index could be challenging.

● Technical capacity is required to develop a hazard index and risk index.

● Interpretation and utilization of the risk indices and maps.
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PART B

STEP-BY-STEP PROCEDURE FOR DROUGHT HAZARD
INDEX DEVELOPMENT

B-1

Drought Hazard Index Development
Drought Hazard Index (DHI) is calculated to assess and quantify the hazard associated with drought
conditions in a particular region. Here we provide a step-by-step procedure to calculate DHI.

Steps for Computing DHI
● Download SPI generator: Use following link and download:

https://drought.unl.edu/Monitoring/SPI/SPIProgram.aspx
● Run the application after extracting all the files
● The application requires MicrosoftNET 4.0 framework and can be compiled as a 32 or 64-bit

executable. The application consists of two files: a vb.net 4.0 application and a c#.net 4.0 DLL.
o ‘SPIGenerator.exe’ – the Windows console application.
o StandardPrecipitationIndex.dll – the SPI DLL.

● The application reads precipitation data and supports different time scales and data types (weekly,
monthly). It outputs SPI data and, optionally, frequency and drought period data. The application
could be run as a Windows GUI (Graphical User Interface) application or executed from the
command line.

o Running as a Windows application produces the following program flow:

Retrieve and verify input parameters >> Parse input file >> Aggregate data >> Calculate
SPI >> Write results to file.

Figure B-1 The main Program Screen of SPI Generator
● Execution of SPI as Windows GUI:

o The application will output data to a space-delimited, comma-separated, or Excel file.
The file format is the same using either the Windows GUI or command line as shown
in Figure B-1.

o Select the Data delimiter based on your input file (Comma or Space) as shown in
Figure B-2.
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(Check Input File if its “Comma” or “Space” separated)

Figure B-2 Format of input dataset

● Select Data Type:Monthly

● Select Data delimiter: (Comma).

● Select File/Directory: File and click to select the sample file for Rainfall data. (Example
dataset is available for area of interest (West Bengal) Observed Climate (1970 to 2019) (Folder
Location: ‘Dataset/Rainfall/His/DistrictName’).

● Select Time Scale: 6 Month (For SPI 6)

● Create an Output Directory: (For example dataset: select file Observed Climate (1970 to 2019)
(Folder Location: ‘Dataset\SPI_Result\WB_SPI_Output_His’) as shown in Figure B-3.

Figure B-3 Example input for SPI Generator

● The calculated SPI 6 values are compared with SPI values corresponding to moderate, severe, and
extreme dry/wet events (refer to the Table B-1).

B-3

Table B-1 SPI Classification based on severity

SPI VALUE CLASSIFICATION
≥ 2.0 Extremely wet

1.5 to 1.99 Very wet
1.0 to 1.49 Moderately wet
-0.99 to 0.99 Near Normal
-1.0 to -1.49 Moderately Dry
-1.5 to -1.99 Severely Dry
-2 and less Extremely Dry

● The SPI value is used to categorize drought as moderate, severe, and extreme based on the
severity. Every class related to drought severity is given a certain weight, and rating scores are
assigned based on the normal cumulative probability function to drought hazard assessment using
severity and occurrence probability. To assign the weight and rating scores:

o Moderate Dry (DWm) when the SPI value is between-1.00 to -1.49 is weighted as 1,
Severely Dry (DWs) when the SPI value is between -1.50 to -1.99 is weighted as 2,
and Extremely Dry (DWe) when SPI value is less than -2 is weighted as 3, and other
SPI classes weighted as 0 as shown in Table B-2.

o Rating scores vary from 1 to 4 in increasing order, splitting the interval of percentage
in each drought range as shown in Table B-2.

o The weights and ratings used to obtain the Drought hazard index (DHI) is based on
Equation 1:

Drought Hazard Index = (DWm x DRm) + (DWs x DRs) + (DWe x DRe) (Equation B-1)

where DRm= ratings assigned to moderate droughts based on a percentage of occurrence;
DWm= weight scores for moderate drought; DRs = ratings assigned to severe droughts based on
a percentage of occurrence; DWs= weight scores for severe droughts; DRe= ratings assigned to
extreme drought based on a percentage of occurrence; DWe= weight scores for extreme drought.

Table B-2 Weights and ratings used to obtain the Drought Hazard Index

Classification Weight Occurrences Rating

Moderately Dry 1

≤ 9.0 1
9.1-10.0 2
10.1-11.0 3
≥11.1 4

Severely Dry 2

≤ 3.5 1
3.6-4.5 2
4.6-5.5 3
≥5.6 4

Extremely Dry 3

≤ 1.5 1
1.6-2.0 2
2.1-2.5 3
≥2.6 4

● Remove the -99 value from the obtained SPI 6; Remove the Date column; Sort the SPI value from
smallest to greatest; Describe the probability distribution (cumulative distribution function (cdf))
and obtain the occurrence assigned rating based on the occurrence value shown in Table 2. Use
equation 1 to obtain the Drought Hazard Index.
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● Sample Results for observed Climate for ‘Alipurduar’ is shown in excel file Folder:
‘Dataset\DHI\Alipurduar_mon_his _SPI_M_06.xlsx’.

● Repeat for all the districts.

● In order to determine the range of hazards for each State, the DHI values of each state are
normalized by dividing it by 1000 to get the final DHI.

● “Calculation of Hazard-specific Exposure Index”. This DHI value would then be combined with
the normalized hazard-specific exposure and vulnerability indicator values to calculate the final
Drought Risk Index (DRI) of each district within the AOI/state (“WB”).
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Flood Hazard Assessment
Identification and delineation of areas prone to flooding in any given region or basin is the first step to 
flood hazard assessment and an important flood prevention tool (Lin et al., 2020). Multiple flood 
modelling techniques exist, each serving a specific purpose in flood risk assessment, mitigation, and 
management. Two of the most common approaches for deriving flood hazard maps are the hydrologic-
hydraulic modelling method (HHM) and the Geographic Information System (GIS) based flood 
susceptibility mapping using multi-criteria decision analysis (MCDA) techniques. Flood susceptibility 
mapping (FSM) integrating GIS and MCDA is the process of assessing and mapping areas that are 
prone to flooding and is a widely used, scientifically robust technique (Mahmoud and Gan, 2018a, 
2018b; González-Arqueros, Mendoza, Bocco, and Castillo, 2018; Das, 2020; Dash and Sar, 2020; Chen, 
2022; Gupta and Dixit, 2022). It involves selection of multiple flood conditioning factors such as 
topography, geography, geomorphology, and rainfall patterns relevant to the study area.

Preparation of the thematic layers 
Flood conditioning factors (also known as flood hazard indicators) are the topographical, hydrological, 
and geological variables that differently and cumulatively influence the occurrence of floods in an area 
(Tehrany et al., 2019). The most relevant and common FCFs are slope, elevation, drainage density (DD), 
soil texture (ST), Topographic Wetness Index (TWI), SPI (probability of occurrence of severe and 
extreme wet events), distance from river (DR), geomorphology, and Land Use Land Cover. Selection 
of these factors can be based on a comprehensive literature review or expert knowledge and is specific 
to the area of study. Therefore, additional factors can be included based on the geographical location.

1. Slope and Elevation

Slope represents the topographic gradient or steepness of a surface, while elevation is the height of a 
particular location from the ground or sea level (i.e., from a fixed reference point). Topographic slope 
and elevation have significant influence upon the processes of surface run-off, infiltration, and water 
accumulation, as well as the flow velocity and flood power (Das, 2020). Hence, areas at lower elevation 
with a flat topography and low slope tend to have greater susceptibility to flooding and water stagnation, 
as opposed to areas at higher elevation and steep slopes (Das, 2020; Gupta & Dixit, 2022; Tehrany et 
al., 2019). 

The raster layers for both factors were extracted from HydroSHEDS DEM of 3-arc seconds resolution 
and divided into five classes ranging from 5 to 1 based on natural breaks in GIS. 

• Preparing the thematic layer: Open GIS platform and add the downloaded India DEM file to the 
interface. Then, add the state boundary shapefile. The DEM file for the concerned state will be 
extracted from the India DEM file using the state boundary shapefile. Hence, the India DEM file is 
clipped to the shape of the state or area of interest (AOI) as shown in Figure C-1.
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Figure C-1 Add the AOI/state boundary shapefile & DEM

• Clip to study area: Add shapefile of the state (state boundary downloaded from Survey of India 
website) to Layers → Go to ‘Geoprocessing’ → Go to ‘Search’ → Search for ‘Clip’ → Select Clip 
(Data Management Tools) → In the ‘Input Raster’, select the India DEM layer (which contains the 
dataset to be clipped) from the dropdown menu → In the ‘Output extent’, select the state boundary 
shapefile (the study state ‘WB’ boundary shapefile in this case) → Check the checkbox that says 
‘Use Input features for clipping geometry’ → In the ‘Output Raster Dataset’, browse to the folder 
where you want to store the files, assign a name (e.g., WB_elevation.tif) and save → Click OK, 
when done. The state DEM layer or elevation layer is the output file (Figure C-2).

Figure C-2 Clip AOI/state boundary DEM from India DEM
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• Slope layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on ‘Spatial Analyst Tools’ → 
‘Surface’ → ‘Click on ‘Slope’ → In ‘Input raster’, select the elevation layer from dropdown menu 
→ In ‘Output raster’, browse to the folder where you want to store the files, assign a name (e.g., 
WB_slope.tif) and save → In ‘Output measurement’, select ‘PERCENT_RISE’ → Click OK. Slope 
layer of the state is now ready (Figure C-3).

Figure C-3 Calculation of percentage slope

• Reclassifying elevation layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on ‘Spatial 
Analyst Tools’ → ‘Go to ‘Reclass’ → ‘Click on ‘Reclassify’ → In ‘ Input raster’, select the elevation 
layer from dropdown menu → Click on ‘Classify’ → Select ‘Natural Breaks’ in the method → 
Select ‘5’ in the classes and click OK → Click on ‘Reverse New Values’ so that class 1 is assigned 
to the highest value of elevation and class 5 is assigned to the lowest value of elevation → In ‘Output 
raster’, browse to the folder where you want to store the files, assign a name (e.g., 
WB_elevation_reclass.tif) and save → Click OK. Elevation layer of the state is now reclassified 
into 5 classes (Figure C-4).



C-5

Figure C-4 Reclassification of elevation layer

• Reclassifying Slope layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on ‘Spatial 
Analyst Tools’ → ‘Go to ‘Reclass’ → ‘Click on ‘Reclassify’ → In ‘ Input raster’, select the slope 
layer from dropdown menu → Click on ‘Classify’ → Select ‘Natural Breaks’ in the method → 
Select ‘5’ in the classes and click OK → Click on ‘Reverse New Values’ so that class 1 is assigned 
to the highest value of slope and class 5 is assigned to the lowest value of slope → In ‘Output 
raster’, browse to the folder where you want to store the files, assign a name (e.g., 
WB_slope_reclass.tif) and save → Click OK. Slope layer of the state is now reclassified into 5 
classes (Figure C-5).
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Figure C-5 Reclassification of slope layer
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2. Drainage Density

Drainage density represents the sum of the stream channel lengths per unit area of the basin (Carlston, 
1963). It is considered a basic parameter influencing the hydrological processes within a basin such as 
infiltration, overland flow, soil saturation, runoff etc. (Gao et al., 2022). A higher drainage density 
indicates higher surface run-off, and thus higher flood susceptibility in regions with a dense stream 
network (Das, 2019). 

The drainage network of the study area was determined from the global HydroRIVERS dataset and 
divided into five classes ranging from 5 to 1 based on natural breaks in GIS. 

Preparing the thematic layer

• Add shapefile of the AOI state: (state boundary downloaded from Survey of India website) to Layers 
Connect dataset folder:  To Add click on    → Add data Box will appear → click  to connect 
dataset folder →Select location to ‘\Dataset’→ Click OK (displayed below in Figure C-6)

Figure C-6 Connect dataset folder

• To add the AOI District shapefile → Double click on Shapefile folder → click on State boundary 
shapefile (‘WB_State’)  → Click ADD (displayed below in Figure C-7).
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Figure C-7 Add the AOI / District shapefile

• To Add the Hydroshed Rivers network shapefile → Double click on Shapefile folder → click on 
Hydrosheds database network shapefile (‘India_HydroRivers.shp’) → Click ADD (displayed 
below in Figure C-8)

Figure C-8 Add the Hydroshed Rivers network shapefile

• Clip to study area: In ArcToolbox, go to ‘Analysis Tools’ →  select the ‘Extract’ → select the ‘Clip’ 
tool → In the ‘Clip features’ window, select the ‘Input Features’, India_HydroRivers layer (which 
contains the dataset to be clipped) from the dropdown menu → In the ‘Clip features’, select the 
layer containing state boundary shapefile (‘WB_state’) → In the ‘Output Feature Class’ browse to 
the folder where you want to store the files, assign a name (e.g., Dataset\Raster\Distance from 
River\WB_HydroRiver.shp) and save → Click OK. (displayed below in Figure C-9)
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Figure C-9 Clip Hydroshed Rivers network shapefile for AOI

• Line Density/ Drainage Density layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on 
‘Spatial Analyst Tools’ → Go to ‘Density’ → Click on ‘Line Density’. A dialog box for ‘Line 
Density’ appears. In ‘Input polyline features’, select ‘stream line’ layer of the state from the 
dropdown menu (e.g., WB_HydroRiver.tif). In ‘Output raster’, browse to the folder where you want 
to store the files, assign a name (e.g., WB_Line_Density.tif) and save → In ‘Output cell size’, 
browse to the folder and select the DEM file, assign a name (e.g., DEM.tif) and save →Click on 
‘Environments’ → A dialog box of ‘Environment Settings’ appear → Go to ‘Processing Extent’ → 
In ‘Extent’, select the ‘state boundary shapefile’ → Now, go to ‘Raster Analysis’ → In ‘Mask’, 
select the ‘state boundary shapefile’ again → Click OK of ‘Environment Settings’ dialog box → 
Click OK of ‘Line Density’ dialog box → Line Density or Drainage Density layer of the state is 
ready (Figure C-10). Uncheck ‘streamline’ layer in the ‘Table of contents’ section, so that 
Line/Drainage Density layer is visible as shown in Figure C-11.
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Figure C-10: Obtain drainage density layer using streamline

Figure C-11 Output drainage density layer 
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• Reclassifying Line/Drainage Density layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → 
Click on ‘Spatial Analyst Tools’ → ‘Go to ‘Reclass’ → ‘Click on ‘Reclassify’ → In ‘ Input raster’, 
select the ‘line density’ layer from dropdown menu → Click on ‘Classify’ → Select ‘Natural Breaks’ 
in the method → Select ‘5’ in the classes and click OK → In ‘Output raster’, browse to the folder 
where you want to store the files, assign a name (e.g., WB_DD_reclass.tif) and save → Click OK. 
Drainage density layer of the state is now reclassified into 5 classes (Figure C-12).

Figure C-12 Reclassification of drainage density layer

• Changing the colour scheme of reclassified DD layer: Right click on ‘reclassified drainage density’ 
layer in the ‘Table of Contents’ section → Click on ‘Properties → A dialog box of ‘Layer Properties’ 
appear → Click on ‘Symbology’ → In ‘Unique values’ section, select a desired color palette in 
‘Color Scheme’ → Click OK (Figure C-13).

Figure C-13 Assign a colour scheme to the reclassified drainage density layer
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3. Topographic Wetness Index (TWI)

This indicator signifies the effect of topography on flow accumulation at any given location in a 
catchment and other hydrological processes (Gokceoglu et al., 2005; Nachappa et al., 2020). The TWI 
is calculated as “ln(a/tanβ), where a is the local upslope area draining through a certain point per unit 
contour length and tanβ is the local slope” (Sorensen et al., 2006). It shows the spatial distribution of 
soil moisture and areas that are prone to generating overland flows (Das, 2020). 

Similar to the generation of slope and elevation layers, HydroSHEDS DEM was used to derive the TWI 
in this study and values reclassified from 1 to 5 as per their susceptibility to flood. A higher TWI 
indicates higher susceptibility to floods.

• Preparing the thematic layer: Open GIS platform and add the downloaded ‘India Flow 
Accumulation’ layer to the interface. Clip to the area of interest after adding the state shapefile as 
shown in slope & elevation. Hence, the India flow accumulation file is clipped to the shape of the 
state or area of interest (AOI).

• Slope in degrees layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on ‘Spatial Analyst 
Tools’ → Go to ‘Surface’ → Click on ‘Slope’. A dialog box for ‘Slope’ appears as shown in Figure 
3-1. In ‘Input raster’, select clipped ‘DEM’ layer of the state from the dropdown menu (add it first) 
→  In ‘Output raster’, browse to the folder where you want to store the files, assign a name (e.g., 
WB_slope_deg.tif) and save → Select ‘DEGREE’ in ‘Output measurement’ → Click OK → Slope 
(in degree) layer is ready (Figure C-14).

Figure C-14 Calculation of degree slope
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• Radius of slope/ Radian slope layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on 
‘Spatial Analyst Tools’ → Go to ‘Map Algebra’ → Click on ‘Raster Calculator.’ A dialog box for 
‘Raster Calculator’ appears. In the expression field as shown in the Figure 3-2 below, add slope in 
degrees layer by double clicking on it, multiply it by 1.570796, and then divide by 90 (whole 
expression will be in a bracket)→ In ‘Output raster’, browse to the folder where you want to store 
the files, assign a name (e.g., WB_radius_slope.tif) and save as shown in the Figure C-15 → Click 
OK → Radian slope layer is ready (Figure C-15).

Figure C-15 Converting slope to radian

• Tan slope layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on ‘Spatial Analyst Tools’ 
→ Go to ‘Map Algebra’ → Click on ‘Raster Calculator.’ A dialog box for ‘Raster Calculator’ 
appears. In the expression field as shown in the Figure 3-3 below, add ‘Con’ by double clicking on 
it, enter a bracket, add radian slope layer by double clicking on it, enter “>0”, enter “,” and then add 
‘Tan’ by double clicking on it. Open a bracket, add radian slope layer again by double clicking on 
it, close the bracket. Enter “,” and then enter 0.001. Close the bracket again. The expression is now 
complete →  In ‘Output raster’, browse to the folder where you want to store the files, assign a 
name (e.g., WB_tanslope.tif) and save → Click OK → Tan slope layer is ready (Figure C-16).
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Figure C-16 Calculation of Tan slope

• Scaled flow accumulation layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on 
‘Spatial Analyst Tools’ → Go to ‘Map Algebra’ → Click on ‘Raster Calculator.’ A dialog box for 
‘Raster Calculator’ appears. In the expression field as shown in the Figure C-17 below, open a 
bracket, add flow accumulation layer of the state by double clicking on it, enter “+1” and then add 
close the bracket → Right click on ‘flow accumulation’ layer of the state in table of contents section 
→ Click on ‘Properties’ → In ‘Layer Properties’, Go to ‘Source’ → In ‘Cell Size’, copy the cell 
size (in this case, it is 0.00083333333) as shown in the Figure C-17→ Paste this cell size in the 
expression field of the ‘raster calculator’ and multiply it by the expression in brackets that was 
entered earlier → The expression is now complete as shown in the Figure C-18→  In ‘Output raster’, 
browse to the folder where you want to store the files, assign a name (e.g., WB_scaled_flowacc.tif) 
and save as shown in the Figure C-18 → Click OK → Scaled flow accumulation layer is ready.
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Figure C-17 Insert formula for scaled flow accumulation layer

Figure C-18 Final scaling of flow accumulation layer
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• TWI layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on ‘Spatial Analyst Tools’ → 
Go to ‘Map Algebra’ → Click on ‘Raster Calculator.’ A dialog box for ‘Raster Calculator’ appears. 
In the expression field as shown in the Figure C-19 below, add ‘Ln’ by double clicking on it, open 
a bracket, add ‘scaled flow accumulation’ layer by double clicking on it and divide it by the ‘tan 
slope’ layer after adding it too. Close the bracket. The expression is now complete →  In ‘Output 
raster’, browse to the folder where you want to store the files, assign a name (e.g., WB_TWI.tif) 
and save → Click OK → TWI layer is ready.

Figure C-19 Calculation of TWI layer using formula Ln (scaled flow accumulation layer / tan 
slope layer)

• Changing colour of TWI layer: Click on the ‘grey colour bar’ present under ‘TWI’ layer in the 
‘Table of Contents’ section which is on extreme left as shown in the Figure C-20 → In the ‘color 
Ramp’, select the desired colour palette from the dropdown menu → Click OK → Colour of TWI 
layer is changed (Figure C-21).

Figure C-20 Change colour of TWI layer for proper visualization

Figure C-21: Result of TWI layer
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• Reclassifying TWI layer: Go to ‘Geoprocessing’ → Select ‘Arc Toolbox’ → Click on ‘Spatial 
Analyst Tools’ → ‘Go to ‘Reclass’ → ‘Click on ‘Reclassify’ → In ‘ Input raster’, select the ‘TWI’ 
layer from dropdown menu → Click on ‘Classify’ → Select ‘Natural Breaks’ in the method → 
Select ‘5’ in the classes and click OK → In ‘Output raster’, browse to the folder where you want to 
store the files, assign a name (e.g., WB_TWI_reclass.tif) and save as shown in the Figure C-22 → 
Click OK. TWI layer of the state is now reclassified into 5 classes. Based on their flood 
control/susceptibility properties low TWI values will belong to very low (1) and high TWI will be 
in very high (5) class and reclassified.

Figure C-22 Reclassification of TWI layer

• Changing the colour scheme of reclassified TWI layer: Right click on ‘reclassified TWI’ layer in 
the ‘Table of Contents’ section → Click on ‘Properties → A dialog box of ‘Layer Properties’ appear 
→ Click on ‘Symbology’ → In ‘Unique values’ section, select a desired color palette in ‘Color 
Scheme’ → Click OK (Figure C-23).

•

Figure C-23 Assign a colour scheme to the reclassified TWI layer
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4.  Geomorphology

Fluvial geomorphological processes result in different erosional and depositional landforms that may 
influence the generation and behaviour of floods in an area to varying degrees. For instance, low lying 
floodplain areas or coastal plains are generally more susceptible to flooding than structural hills. The 
geomorphological data of the study area was obtained from the Geological Survey of India’s Bhukosh 
database available at 1:250,000 resolution. Please see link: 
https://bhukosh.gsi.gov.in/Bhukosh/MapViewer.aspx1. The different geomorphological landforms are 
reclassified into very low, low, moderate, high, and very high categories (class 1 to 5) depending upon 
their control or susceptibility to floods in a given area. 

• Preparing the geomorphology layer: Open GIS platform and add the downloaded geomorphology 
shapefile for the concerned state to the interface (Figure C-24B). The image on the right (C-24A) 
shows the map for an area extending beyond the boundary of the study state - WB2. Hence, it has 
to be clipped to the shape of the study area or area of interest (AOI). 

Figure C-24 Add geomorphological shapefile to GIS

• Clip to study area: Add shapefile of the state (state boundary downloaded from Survey of India 
website) to Layers (Figure C-25A)→ Go to ‘Geoprocessing’ → select the ‘Clip’ tool (Figure C-
25B)→  → In the ‘Input Features’, select the geomorphology layer (which contains the dataset to 
be clipped) from the dropdown menu  (Figure C-25C)→ → In the ‘Clip features’ box, select the 
layer containing your AOI (the study state ‘WB’ boundary shapefile in this case) → In the ‘Output 
Feature Class’ browse to the folder where you want to store the files, assign a name (e.g., 
WB_geom_clip.shp) and save → Click OK, when done (overall step shown in Figure C-25). 

1 You will need to register as a user in the website in order to be able to download the required dataset.
2 Dummy state used as an example for this manual.
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Figure C-25 Clip geomorphological shapefile to AOI

• Uncheck/Turn off all layers other than the clipped AOI as shown in Figure C-26.

Figure C-26 Visualization of clipped geomorphology shapefile
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• Explore the different landforms within the AOI using the steps illustrated below. The output would 
look similar to (Figure C-27).

Figure C-27 Visualize geomorphology shapefile based on description classes

• Details of the different landform classes can be viewed in the ‘Attribute Table’. As shown below 
(Figure C-28), the field ‘DESCRIPTION’ contains a more elaborate description of the 
geomorphological class, while field ‘LEGEND_SHORT’ contains the same information in a 
concise manner. Example: ‘Active Floodplain’ and ‘Older Floodplain’ classes in the former are 
categorized as the common class of ‘Floodplain’ in the latter. 
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Figure C-28 Visualize elaborate description of the geomorphology class

• Combine the multiple polygons under the same landform feature (common atrribute value) using 
the ‘Dissolve’ tool under ‘Geoprocessing’, as displayed below in Figure C-29. Go to Geoprocessing 
→ Dissolve → In the Input Features, select the shapefile ‘WB_geom_clip’ → Assign a name (e.g., 
WB_geom_clip_dissolve.shp) and save to the same folder as the previous files in Output Feature 
Class-->In ‘Dissolve_Field(s)’, select either the ‘DESCRIPTION’ field or the ‘LEGEND_SHORT’, 
based on which the combination would take place → OK. 

Figure C-29 Dissolve geomorphology layer based on description classes
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• The dissolved output (Figure C-30A) can be explored by adding the unique values in ‘Symbology’ 
and selecting the relevant ‘Value Field’ as ‘DESCRIPTION’. The color ramp can be adjusted to 
view the layer as per user preference. The steps to be followed are similar to Figure C-27. The 
attribute table displayed in shows the Figure C-30B different landform types present in the sample 
AoI displayed here.

Figure C-30 Check description of the dissolved geomorphology class

• Conver to raster: In order to rate and reclassify these landforms according to their susceptibility to 
flooding, the shapefile needs to be converted to a raster file. Figure C-31 given below describes the 
steps to be followed for achieving this. In ArcToolbox, go to Conversion Tools → Raster →  
Polygon to Raster → Select ‘WB_geom_clip_dissolve’ in Input Features → Select 
‘DESCRIPTION’ in Value Field → Name the Output Raster Dataset (e.g., 
WB_geom_polytoraster.tif) and save in relevant folder → In ‘Cellsize’, select the DEM file of the 
study area → click OK once done. The output raster would appear as shown in Figure C-31 
(bottom).
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Figure C-31 Convert dissolved geomorphological shapefile to raster

• Reclassify: Different landforms influence flood occurrence in any given area in different forms and 
degree. Based on expert opinion and geomorphological knowledge of the study area, the various 
landform classes have to be rated from 1 to 5, signifying flood characteristics and reclassified for 
the final overlay. The steps to be followed are displayed in Figure C-32:  Go to ‘Spatial Analyst 
Tools’ in ArcToolbox → Reclass → Reclassify → In the window that appears, select the raster file 
that needs to be reclassified in ‘Input raster’, i.e., WB_geom_polytoraster → Select 
‘DESCRIPTION’ in ‘Reclass field’ → Assign the flood susceptibility rating in ‘New values’ → 
Click OK after saving the output raster in the required folder. The final reclassified geomorphology 
layer would be obtained as shown below in. Figure C-33.

Figure C-32 Reclassification of geomorphology layer
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Figure C-33 Reclassified geomorphology layer

• In order to display it according to the reclassified values, go to Layer Properties → Symbology → 
Unique Values → Select ‘Value’ in Value Field instead of ‘DESCRIPTION’ → select a color scheme 
of choice (here we have used the blue ramp) → Add All Values → Apply → OK (Figure C-34). The 
output raster would appear as shown in Figure C-35. This raster thematic layer will then be assigned 
a weight based on the AHP analysis and overlaid with the eight other FCFs to obtain the composite 
FSM of the AOI.

Figure C-34 Assign a colour scheme to the reclassified geomorphology layer
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Figure C-35 Output result of reclassified geomorphology layer with colour scheme

5.  Soil Texture

The soil data was obtained from the Food and Agricultural Organization of the United Nations (FAO) 
and classified into five classes based on its properties and relation to water holding capacity. Given is 
the link for downloading the vector dataset (Digital Soil Map of the World) at 1: 5000000 scale: 
https://www.fao.org/soils-portal/data-hub/soil-maps-and-databases/faounesco-soil-map-of-the-
world/en/ and https://data.apps.fao.org/map/catalog/srv/eng/catalog.search#/metadata/446ed430-8383-
11db-b9b2-000d939bc5d8. 

Steps for preparing the Soil Texture layer for FSM:

• Add the Digital Soil Map of the World (DSMW) to the GIS interface as shown below (Figure C-
36A). Once the layer has been added, you can change the symbology (Figure C-36B) to view the 
map in terms of the DOMSOI value field, which is the code for the dominant soil unit (covering 
40% of the mapping unit). The output would appear as shown in Figure C-37. 

Figure C-36 Add the Digital Soil Map of the World (DSMW) to the GIS
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Figure C-37 Digital Soil Map of the World (DSMW) of world

• Define projection for ‘DSMW’ - The DSMW shapefile in Figure C-37 will show ‘unknown spatial 
reference’. So, to define a projection. Go to Arc Toolbox → Click Data Management Tools → Click 
on Projections and transformation → Click Define Projection → ‘Define Projection’ window will 
pop-up → In ‘Input Dataset or Feature Class’ browse and select the Soil files ‘DSMW’ → In 
Coordinate System (Figure C-38) → ‘Spatial Reference Properties’ window will popup → Select 
‘Geographic Coordinate System’ → Select ‘World’ → Select ‘WGS 1984’ → Select ‘OK’ 
(GCS_WGS_1984) → Select ‘OK’.

Figure C-38 Define projection for Digital Soil Map of the World shapefile

• Clip to Soil Map for India: Add shapefile of the all-India boundary (India boundary downloaded 
from Survey of India website) to Layers → Go to ‘Geoprocessing’ → select the ‘Clip’ tool (also 
shown in Figure C-25). → In the ‘Input Features’, select the ‘Soil’ layer (which contains the dataset 
to be clipped ‘DSWM’) from the dropdown menu → In the ‘Clip features’ box, select the layer 
containing your country boundary shapefile (the country boundary shapefile in this case 
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‘India_wgs1984.shp’) → In the ‘Output Feature Class browse to the folder where you want to store 
the files, assign a name (e.g., India_FAOSoil.shp) and save → Click OK (show in Figure C-39). 

Figure C-39 Clip India soil layer from world soil layer

• Clip for the required AOI (study state/district/block) – Using the shapefile of the dummy state 
‘WB_State’, the ‘India_FAOSoil’ dataset will need to be clipped to the AOI. The clip tool can be 
accessed directly from the ‘Geoprocessing’ tab present at the top of the interface (also shown in 
Figure C-25). In the ‘Input Features’, select the clipped India soil layer (eg, ‘India_FAOSoil.shp’) 
from the dropdown menu → In the ‘Clip features’ box, select the layer containing your AOI (the 
study state boundary shapefile in this case ‘WB_state.shp’) → In the ‘Output Feature Class browse 
to the folder where you want to store the files, assign a name (e.g., WB_FAOSoil.shp) and save → 
Click OK, when done (this step will be similar to the step shown in Figure C-39) Once the AOI has 
been clipped from the larger dataset, the map for the dummy state would look like Figure C-40A) 
given below (categorized according to the DOMSOI value field in ‘Symbology’). The Legend in 
Figure C-40 B shows the names for the DOMSOI units3 in WB.  

3 The names of the DOMSOI units are available in the map legend of the Digital Soil Map of the World (pdf 
file). 
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• Through expert opinion and literature review, these soil units can be rated from very low to very 
high flood control characteristics according to their texture, infiltration, and run-off properties. The 
raster format of the soil map for the AOI can then be reclassified into five classes signifying the 
flood susceptibility. 

• Alternately, these soil units can further be categorized based on their texture (percentage 
composition of sand, silt, and clay) as ‘clay/loam/sandy loam/clay loam’ etc., which would be rated 
and reclassified for the final overlay. The textural classes to the FAO soil mapping units can be 
assigned based on the ‘usersoil’ excel file of the SWAT soil database (Figure C-41). This SWAT 
dataset contains detailed characteristics, including texture, hydrological group, percentage of sand, 
silt, and clay etc., of different soil units.

However, to join the SWAT ‘usersoil’ table with the attribute table of the FAO soil map, further 
processing is required as explained below. 

• From the attribute table in Figure C-41, it can be seen that there are around 65 different polygons 
representing the soil mapping units in WB. The next step would be to aggregate the features based 
on specified attributes using the Dissolve function. The SNUM field in the attribute table represents 
sequential code unique for each soil Mapping Unit (see Figure C-41). Therefore, to aggregate the 
similar soil mapping units, go to Geoprocessing → Dissolve → Select ‘WB_FAOSoil’ in Input 
Features → Assign a name (WB_FAOSoil_dissolve.shp) and save to related folder in Output 

Figure C-41 SWAT ‘usersoil’ classification

Figure C-40 Visualize soil categories based on DOMSOI value field
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Feature Class → Select the ‘SNUM’ field in Dissolve_Field(s) (Optional) → OK Figure C-42). The 
output and its attribute table would be similar to Figure C-43 after adjusting the symbology and 
assigning a color ramp. 

Figure C-42 Dissolve soil layer based on SNUM classes

Figure C-43 Visualize dissolve soil layer based on SNUM classes
• Joining of ‘usersoil’ table to attribute table of the dissolved layer (WB_FAOSoil_dissolve): Add 

‘usersoil’ excel sheet to the interface (Figure C-44).
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• Next, as shown in Figure C-45, right click on WB_FAOSoil_dissolve layer → Joins and Relates → 
Join → In the window that appears, select ‘Join attributes from a table’ from the drop-down menu 
under ‘What do you want to join to this layer?’ → select SNUM in ‘1.’ → choose ‘usersoil$’ sheet 
in ‘2.’ → choose ‘SEQN’ in ‘3.’ → Check ‘Keep all records in ‘Join Options’ → Validate Join → 
OK. Thus, the join will be based on the field ‘SNUM’ of the FAO Soil data table and ‘SEQN’ field 
of the SWAT usersoil sheet, which match each other and is unique and common to each soil unit of 
both datasets. The resultant attribute table of WB_FAOSoil_dissolve post joining will appear as 
shown in Figure C-46.

Figure C-45 Joining of ‘usersoil’ table to attribute table of the dissolved soil layer

Figure C-44 Add usersoil excel sheet to GIS
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Figure C-46 Visualize joined ‘usersoil’ sheet in soil layer attribute table

• Export as a new shapefile: Once the join has been executed, export the data as a new shapefile. 
Right click on WB_FAOSoil_dissolve → Data → Export Data → Select ‘All features’ in ‘Export:’ 
→ Save as a new shapefile in ‘Output feature class’ (E.g., WB_FAOSoil_withtexture) → OK 
(Figure C-47). The new output shapefile ‘WB_FAOSoil_withtexture.shp’ would contain the 
combination of all properties as described in the DSMW dataset and the SWAT database. The 
resultant attribute table would appear as shown below in Figure C-48. The soil texture types present 
in the study area can be viewed by changing the ‘value field’ under Symbology (in Layer properties) 
to ‘Texture’ as given in Figure C-49. Based on their flood control/susceptibility properties 
determined by their run-off characteristics, the different soil textural types will be rated between 
very low (1) and very high (5) and reclassified. 

Figure C-47 Export soil layer to new shapefile



C-32

Figure C-48 Soil property and its flood susceptibility

Figure C-49 Visualize soil layer based on texture property of soil

• Polygon to raster: To rate and reclassify the soil texture, the shapefile ‘WB_FAOSoil_withtexture’, 
will need to be converted to raster format. Figure C-50 given below describe the steps to be followed 
for achieving this. In ArcToolbox, go to Conversion Tools → Raster → Polygon to Raster → Select 
‘WB_FAOSoil_withtexture’ in Input Features → Select ‘Texture’ in Value Field → Name the 
Output Raster Dataset (e.g., WB_texture.tif) and save in relevant folder → In ‘Cellsize’, select the 
DEM file of the study area → click OK. The converted file (WB_texture.tif) would appear as 
displayed below in Figure C-51.

Figure C-50 Convert soil shapefile to raster based on soil texture
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• Reclassify: Go to ArcToolbox → Spatial Analyst Tools → Reclass → Reclassify → Select 
WB_texture.tif in Input raster → ‘Texture’ in Value Field → Add the ratings (between 1 and 5) as 
New Values → Click OK after saving the output raster (WB_texture_reclassify.tif) in the required 
folder as the one shown in Figure C-51. The final reclassified soil texture layer would be obtained 
as the one shown in Figure C-52. This raster would then be assigned a weight based on the AHP 
analysis and overlaid with the eight other FCFs to obtain the composite FSM of the AOI.

Figure C-51 Reclassification of soil layer

Figure C-52 Output result of reclassified soil layer with colour scheme

6. Distance from River (DR)

In this indicates the major pathways of flood discharge and its spread. Generally, areas adjacent to rivers 
are more vulnerable to inundation as water overflows and spreads laterally, than those located further 
away from the banks. The River Network data of the study area was obtained from the Hydrosheds 
database available at https://www.hydrosheds.org/products/hydrorivers1. In this study, DR was 
calculated using the ‘Euclidean distance’ tool in GIS and classified into five classes (5, 4, 3, 2, 1) based 
on natural breaks/jenks. The class with the lowest range of distance from the river was classified as 5, 
indicating ‘very high’ flood susceptibility, and the range with the largest DR as 1, indicating ‘very low’ 
susceptibility.
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• Add shapefile of the AOI state (state boundary downloaded from Survey of India website) to Layers 
→ To Add data click   → Add data Box will appear → click  to connect dataset folder 
→Select location to ‘\Dataset’→ Click OK (displayed below in Figure C-53)

Figure C-53 Connect dataset folder

• To Add the SOI District shapefile → Double click on Shapefile folder → click on State boundary 
shapefile (‘WB_State’)  → Click ADD (displayed below in Figure C-54).

Figure C-54 Add the AOI / state boundary shapefile
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• To Add the Hydroshed Rivers network shapefile → Double click on Shapefile folder → click on 
Hydrosheds database network shapefile (‘India_HydroRivers.shp’) → Click ADD (displayed 
below in Figure C-55)

Figure C-55 Add the Hydroshed Rivers network shapefile

• Clip to study area: In ArcToolbox, go to ‘Analysis Tools’ →  select the ‘Extract’ → select the ‘Clip’ 
tool → In the ‘Clip features’ window, select the ‘Input Features’, India_HydroRivers layer (which 
contains the dataset to be clipped) from the dropdown menu → In the ‘Clip features’, select the 
layer containing state boundary shapefile (‘WB_state’) → In the ‘Output Feature Class’ browse to 
the folder where you want to store the files, assign a name (e.g., Dataset\Raster\Distance from 
River\WB_HydroRiver.shp) and save → Click OK. (displayed below in Figure C-56)

Figure C-56 Clip Hydroshed Rivers network shapefile for AOI

• Extract Major River Network: Mainly the flood causes in the main river therefore consider only the 
high order streams. 

• In Table of Contents, right click Clipped River network shapefile (‘WB_HydroRiver’) → Click 
Open Attribute Table →  In ‘Table’ window go to ORD_STRA column Double Click (To sort 
column double Click) (displayed below in Figure C-57)
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Figure C-57 Sort attribute table having stream order Strahler

• Select all row where ORD_STRA is more than ‘4’ (main river network is present in all stream order 
more than 4) → Go to Table of Contents, right-click shapefile ‘WB_HydroRiver’ → Click ‘Data’ 
→ Click ‘Export Data’ → ‘Export Data’ window will pop-up, Name the Output Raster Dataset (e.g., 
‘Dataset\Raster\Distance from River\WB_River_4_8.shp’) and save in relevant folder → click OK 
→‘ArcMap’ window will pop-up to ask do we want to add export layer in to map, to add click Yes. 
(displayed below in Figure C-58)

Figure C-58 Extract main river network having stream order more than 4
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• Distance from River Network: In ArcToolbox, go to ‘Spatial Analysis Tools’ → Select the ‘Distance’ 
→ Select the ‘Euclidean Distance’ tool → In the ‘Euclidean Distance’ window, select the ‘Input 
raster or  features’, which contains the Extract Major River Network (‘WB_River_4_8 layer’) from 
the dropdown menu → In the ‘Output Distance Raster’ browse to the folder where you want to store 
the files, assign a name (e.g., Dataset\Raster\Distance from River\WB_DR.tif) and save → In 
‘Output cell size’, select the DEM file of the study area (‘Dataset\Raster\DEM.tif) ‘→click 
‘Environment Settings’ → In ‘Processing Extent’ Select the layer containing state boundary 
shapefile of AOI (‘WB_state’) → In ‘Mask’ select the DEM file of the study area 
(‘Dataset\Raster\DEM.tif‘)→ click OK → click OK (displayed below in Figure C-59).

Figure C-59 Calculate Euclidean distance for the river network

• Reclassify: The class with the lowest range of distance from the river was classified as 5, indicating 
‘very high’ flood susceptibility, and the range with the largest DR as 1, indicating ‘very low’ 
susceptibility. In ArcToolbox, go to ‘Spatial Analyst Tools’ → Select the ‘Reclass’ → Select the 
‘Reclassify’ → ‘Reclassify’ Window will pop-up, select the output of Euclidean Distance  
(‘WB_DR.tif’) in ‘Input raster’ → Click Classify → Classification Window will pop-up, Select 
‘Natural Break’ in ‘Classification Method’ → Select ‘5’ in ‘Classes → click OK → Change 
Reclassification ‘New Values’ as per below figure (Near to river will get higher value ‘5’ and far 
away from river will get less value ‘1’) → In ‘Output Raster’ select relevant folder and assign file 

name (‘Dataset\Raster\Distance from River\WB_DR_reclassify.tif‘) → Click  in ‘change 
missing values to No Data’→ click OK. (displayed below in Figure C-60).
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Figure C-60 Reclassified distance from river layer

• Changing the colour scheme of reclassified DR layer: Repeat same step as followed in previous 
section of changing the colour scheme of reclassified layer. Result of DR is shown in Figure C-61.

Figure C-61 Output result of reclassified distance from river layer with colour scheme
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7. Land use/land cover (LULC)

The land use/land cover data of the study area was obtained from the Sentinel-2 10m Land Use/Land 
Cover Timeseries layer database available at 10 m resolution or any other product can also be use. For 
downloading Sentinel-2 10m Land Use/Land Cover Timeseries layer for year 2019 please see link: 
https://www.arcgis.com/home/item.html?id=fc92d38533d440078f17678ebc20e8e2 4. The data is 
classified in to 9 classes. The classes are Water Areas, Trees (any significant clustering of tall (~15-m 
or higher) dense vegetation), flooded vegetation areas (flooded area that is a mix of 
grass/shrub/trees/bare ground), Crops (Human planted/plotted cereals, grasses, and crops not at tree 
height; examples: corn, wheat, soy, fallow plots of structured land), Built Area (human made structures), 
bare ground areas (rock or soil with very sparse to no vegetation), Snow/Ice Large, Clouds (no land 
cover information due to persistent cloud cover), rangeland (open areas covered in homogenous grasses) 

The different land use/land cover are reclassified into very low, low, moderate, high, and very high 
categories (class 1 to 5) depending upon their control or susceptibility to floods in a given area. 

Download Land Use /Land cover data: Open Link 
https://www.arcgis.com/home/item.html?id=fc92d38533d440078f17678ebc20e8e2 (as shown in 
Figure C-62)→ Select the Tiles and the location of AOI / State → Window will pop-up, ‘Download 
Scene by year’ select the year ‘2019’ → The file will be start downloading (as shown in Figure C-63). 
If the AOI / State is located in a manner that requires downloading multiple tiles. So based on AOI / 
State download the land use land cover map.    

Figure C-62 Land Use /Land cover data portal. 

4 You will need to register as a user in the website in order to be able to download the required dataset.

Figure C-63 Download Land Use /Land cover data
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• Add shapefile of the state (state boundary downloaded from Survey of India website) to Layers → 
To Add data click   → Add data Box will appear → click  to connect dataset folder →Select 
location to add and store file (‘\Dataset’)→ Click OK(as shown in Figure C-64)

Figure C-64 Connect dataset folder

• To Add the SOI District shapefile of AOI → Double click on Shapefile folder → click on State 
boundary shapefile (‘WB_State’) → Click ADD(as shown in Figure C-65)

Figure C-65 Add the AOI / State shapefile

• To Add Land Use /Land cover → Double click on Raster folder → Double click on Landuse folder 
→ Double click on Raw folder → select all raster file for AOI (both files) → Click ADD(as shown 
in Figure C-66) (For example AOI/state, the AOI/State is situated in a way that two land-use tiles 
cover the extent of the AOI/State).
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Figure C-66 Adding the Land Use /Land cover data to GIS

• Define projection for ‘Land Use /Land cover’: This step needs to be performed for all the tiles 
download for AOI.  In ArcToolbox, go to ‘Data Management Tools’ → Select the ‘Projection and 
Transformation’ → Select the ‘Raster’ → Select ‘Project Raster’ → ‘Project Raster’ Window will 
pop-up → Select ‘Input Raster’ as Landuse raster file for AOI (‘45R_20190101-20200101.tif’) → 
Input file name the ‘Output Raster Dataset’ (e.g., ‘Dataset\Raster\Landuse\ 45R_20190101-
20200101_GCS.tif’) and save in relevant folder → Select ‘Output Coordinate System’ as 
‘GCS_WGS_1984’ → click OK (as shown in Figure C-67).

Figure C-67 Projecting Land Use /Land cover raster
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• (If you have a single tile for your AOI/State, then you need to skip this step.)
Repeat Define projection for all the tiles raster file: In ArcToolbox, go to ‘Data Management Tools’ 
→ Select ‘Projection and Transformation’ → Select ‘Raster’ →‘Project Raster’ Window will pop-
up → Select ‘Input Raster’ as land use raster file for AOI (‘45Q_20190101-20200101.tif’) → Input 
file name the ‘Output Raster Dataset’ (e.g., ‘Dataset\Raster\Landuse\ 45Q_20190101-
20200101_GCS.tif’) and save in relevant folder → Select ‘Output Coordinate System’ as 
‘GCS_WGS_1984’ → click OK (If you have multiple tile for your AOI/State than you have to 
repeat the step for all tiles)

• Clip for the required AOI (study state/district/block) – Using the state boundary shapefile of the 
AOI (‘WB_State’) and add the projected Landuse raster file (‘45Q_20190101-20200101_GCS.tif’ 
& ‘45R_20190101-20200101_GCS.tif’) dataset will need to be clipped to the AOI. In ArcToolbox, 
go to ‘Data Management Tools’ → Select the ‘Raster’ → Select the ‘Raster Processing’ → Select 
the ‘Clip’ →‘Clip’ Window will pop-up → Select projected landuse raster file (‘45Q_20190101-
20200101_GCS.tif’ OR ‘45R_20190101-20200101_GCS.tif’) in the ‘Input Raster’ → Select 
‘Output Extent’ as the state boundary shapefile of the AOI (‘WB_state’)→ Check Mark Use ‘Input 
Feature for Clip Geometry’ → and to save in relevant folder Select ‘Output Raster Dataset’ as 
(‘Dataset\Raster\Landuse\Clip\’ ‘45Q_20190101-20200101_GCS_C.tif’ OR ‘45R_20190101-
20200101_GCS_C.tif’) → click OK (as shown in Figure C-68 for 45Q and Figure C-69 for 45R) 
(If you have more than two tiles for your AOI/State, repeat the step for each tile).

Figure C-68 Clip Land Use /Land cover raster 1 to AOI
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Figure C-69 Clip Land Use /Land cover raster 2 to AOI

• Combine the cliped multiple Raster file: Go  to ‘Data Management Tool’ → Select the ‘Raster’ → 
Select the ‘Raster Dataset’→ Select the ‘Mosaic to New Raster’ →  In the ‘Input Raster’, select all 
the Projected cliped raster file of land use (‘45Q_20190101-20200101_GCS_C.tif’ & 
’45R_20190101-20200101_GCS_C.tif’) → Select relevant folder (‘Dataset\Raster\Landuse\’) in 
‘Output Location’ → ‘Assign a Raster Dataset name with Extension (e.g., ‘WB_LULC.tif’) → 
Select ‘Number of Bands’ as ‘1’ →  OK. as shown in Figure C-70.

• If you have a single tile for your AOI/State, skip this step.

Figure C-70 Mosaic multiple raster file to single raster file

• Reclassify: The different land use/land cover are reclassified into very low, low, moderate, high, 
and very high categories (class 1 to 5) based on the property. In ArcToolbox, go to ‘Spatial Analyst 
Tools’ → Select the ‘Reclass’ → Select the ‘Reclassify’ → Window will pop-up, select the Mosaic 
Land use raster file (‘Dataset\Raster\Landuse\WB_LULC.tif’) in ‘Input raster’ → Click on Unique 
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→ In ‘Reclassify’ Select New Values Based on below window → In ‘Output Raster’ select relevant 
folder and assign file name (‘Dataset\Raster\Landuse\WB_LULC_reclassify.tif)→ click OK. as 
shown in Figure C-71. (Variations in land use, land cover, and flood susceptibility across different 
regions are quite common. So, the classification of land use classes varies with respect to flood 
susceptibility classes, indicating that different types of land use exhibit distinct levels of flooding. 
This variability could be attributed to factors such as land cover, topography, and urban 
development, which influence how different areas respond to and are impacted by flood events. So 
based on you AOI we need to reclassify this flood susceptibility classes. Example for our AOI is 
shown in Table C-1)

Table C-1: Example for reclassification of land use, land cover, and flood susceptibility classes

Flood Susceptibility class Land use class

1 Clouds (10), Snow/Ice (9)

2 Trees (2)

3 Crops (5), Rangeland (11)

4 Flooded vegetation (4), Built Area (7)

5 Water (1), Bare ground (8)

Figure C-71 Reclassification of land use, land cover layer

• Changing the colour scheme of reclassified LULC layer: Repeat same step as followed in previous 
section of changing the colour scheme of reclassified layer. Result of LULC is shown in Figure C-
72
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Figure C-72 Output result of reclassified land use land cover layer with colour scheme

8. Standardized Precipitation Index (SPI)

The states will receive the district-level monthly precipitation data (50 years, tentatively) from the 
Project Team (in an excel format) for both Observed, and RCP scenarios.

• Download SPI generator from the following link and run the application after extracting all the 
files: https://drought.unl.edu/Monitoring/SPI/SPIProgram.aspx

• The application requires MicrosoftNET 4.0 framework and can be compiled as a 32- or 64-bit 
executable. The application consists of two files: a vb.net 4.0 application and a c#.net 4.0 DLL.

● ‘SPIGenerator.exe’ – the Windows console application.

● StandardPrecipitationIndex.dll – the SPI DLL.

• The application reads in precipitation data and supports different time scales and data types (weekly, 
monthly). It outputs SPI data and, optionally, frequency and drought period data. In addition to 
executing as a Windows GUI (Graphical User Interface) it can also execute from the command line.

• Running the application as a Windows application or command line produces the same program 
flow:

i. Retrieve and verify input parameters

ii. Parse input file

iii. Aggregate data

iv. Calculate SPI

v. Write results to file.

• Execution of SPI as Windows GUI (Figure C-73):
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Figure C-73 SPI Generator user interphase

• The application will output data to a space-delimited, comma-separated, or Excel file.  The file 
format is the same using either the Windows GUI or command line.

• Select Data delimiter based on your input file (Comma or Space). (Figure C-74). Check Input File 
if its “Comma” or “Space” separated).

  Figure C-74 Format of input file

• Select Data Type Monthly 

• Select Data delimiter (Comma). 

• Select File Sample file for Rainfall data. (Example dataset is available for area of interest (West 
Bengal) Observed Climate (1970 to 2019) (Folder Location: ‘Dataset/Rainfall/His/DistrictName’).

• Select Time Scale: 6 Month (For SPI 6)

• Create output Directory. (For example dataset: select file Observed Climate (1970 to 2019) (Folder 
Location: ‘Dataset\SPI_Result\WB_SPI_Output_His’(Figure C-75).
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Figure C-75 Example input for SPI generator

• The calculated SPI 6 values are compared with SPI values corresponding to moderate, severe, and 
extreme dry/wet events (refer to Table C-2 below). 

Table C-2 SPI index classification

SPI VALUE CLASSIFICATION
≥ 2.0 Extremely wet

1.5 to 1.99 Very wet
1.0 to 1.49 Moderately wet

-0.99 to 0.99 Near Normal
-1.0 to -1.49 Moderately Dry
-1.5 to -1.99 Severely Dry
-2 and less Extremely Dry

• The probability of occurrence of dry/wet events could then be expressed as the number of severe + 
extreme events (as per SPI value), divided by the total number of events (595) [SPI 6 is calculated 
on a monthly basis for a moving window of 6 months, that’s why we have -99 values for first 
5 months. Delete these first five null values].5

• The output of this assessment is in percentage, representing the probability for a hazard to 
occur. The probability of occurrence of dry or wet events could be expressed as the number of 
events of a given type and the severity of hazard. 

 Important note: Delete the first five “-99” values and then calculate spi6 for dry and wet events.
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• Sample Results for observed Climate for ‘Alipurduar’ is shown in excel file Folder: 
‘Dataset\SPI_probability_of_occurrence\Alipurduar_mon_his_50.txt_SPI_M_06.xlsx’. (Included 
with formula for calculation) (Figure C-76).

Figure C-76 Sample results for probability of occurrence of dry/wet events

• Similarly, summary of probability of occurrence of dry or wet events for all the district of West 
Bengal in Observed Climate (‘SPI_WB_HIS’), sample calculated, and result is stored in Location: 
‘Dataset\SPI_probability_of_occurrence\’.

• Preparing the SPI layer: Open GIS platform, connect dataset folder, and add the SOI shapefile for 
the concerned AOI (West Bengal state to the interface ‘\Dataset\Shapefile\WB_district.shp’). 

• To add data, click   → Add data Box will appear → click  to connect dataset folder →Select 
location to ‘\Dataset’→ Click OK (Figure C-77).

Figure C-77 Connect dataset folder
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• To Add the SOI District shapefile → Double click on Shapefile folder → click on File AOI district 
shapefile (the study state WB_district shapefile in this case)  → Click ADD (Figure C-78).

Figure C-78 Add the AOI / District shapefile

• Prepare File to connect SPI value of District with AOI (WB_district) district shapefile:
In the ‘Table of Contents’ layer  → Right Click on shapefile → Click on Open Attribute Table  
→Use FID and District name to relate with Excel file where SPI values (Figure C-79) → probability 
of occurrence of dry or wet events for all the district of AOI (West Bengal) in Observed Climate 
(‘SPI_WB_HIS’) result is stored in Location: ‘Dataset\SPI_probability_of_occurrence\’.

Figure C-79 Get FID and district name from attribute table
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• As shown in Figure C-80, select All Row of Table  → Right Click → Click on Copy Selection → 
Open Excel Sheet 

Figure C-80 Extract detail from attribute table

• Prepare Excel Sheet (Figure C-81): Paste the copied attribute table to new excel sheet. → And also 
Paste the probability of occurrence of dry or wet events for all the district of AOI (the district of 
West Bengal) in Observed Climate (‘SPI_WB_HIS’) → Sample file is located in: ‘Dataset\ 
SPI_probability_of_occurrence\SPI_Joint_His.csv’. 

Figure C-81 Integration of FID with probability of occurrence of wet event

• To Add data click   → Add data Box will appear → click  to  connect dataset folder →Select 
location to ‘\Dataset\shapefile’→ Select file Prepared Excel Sheet in last step (‘SPI_Joint_His.csv’) 
→ Click ADD (Figure C-82).
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Figure C-82 Add CSV file to GIS

• Go to Table of Contents layer  → Right Click on district shapefile of AOI (‘WB_district’) → Click 
on Join and Relates  →Click on Join →Join Data Box will pop-up→ 1st Choose the field in this 
layer that the join will be based on: Select FID → 2nd Choose the table to Join to the Layer Select 
Prepared Excel Sheet (‘SPI_Joint_His.csv’) → 3rd Choose the field in the table to base the Join on: 
Select FID → Click on Validate Join → Click OK (Figure C-83).

Figure C-83 Joins and relates added CSV to AOI / District shapefile

• Go to Table of Contents layer  → Right Click on shapefile → Click on Open Attribute Table → 
Check all Joint are Joined (Figure C-84).
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Figure C-84 Attribute Details of the Integrated Probability of Occurrence of Wet Events - CSV 
File and AOI/District Shapefile

• In ArcToolbox, go to Conversion Tools → Raster →  Polygon to Raster → Select district shapefile 
of AOI with connected excel sheet having probability of wet/ dry event (‘WB_district’) in Input 
Features → Select the column have the probability of wet event for observed climate 
(‘SPI_Joint_His_HisProb_wet’) in ‘Value Field’ → Name the Output Raster Dataset (e.g., 
‘Dataset\Raster\SPI_HIS.tif’) and save in relevant folder → In ‘Cellsize’, select the DEM file of 
the AOI (‘Dataset\Raster\DEM.tif) ‘→ click ‘Environment Settings’ → select the DEM file of the 
AOI (‘Dataset\Raster\DEM.tif ‘) in ‘Mask’ → click OK → click OK (Figure C-85).

Figure C-85 Convert probability of occurrence of wet events from shapefile to raster
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• Reclassify: Probability of occurrence of severe and extreme wet event the higher value will be more 
susceptible to flood. Therefore, lowest value to highest value will be reclassify in the classes have 
rated from 1 to 5. As shown in Figure C-86, in ArcToolbox, go to ‘Spatial Analyst Tools’ → Select 
the Reclass → Select the Reclassify → Window will pop-up, select the SPI layer for observed obtain 
in last step (‘Dataset\Raster\SPI_HIS.tif’) in ‘Input raster’ → Click Classify → Classification 
Window will pop-up, Select ‘Equal Interval’ in ‘Classification Method’ → Select ‘5’ in ‘Classes → 
click OK → In ‘Output Raster’ select relevant folder and assign file name 

(‘Dataset\Raster\SPI_HIS_reclassify.tif’)→ Click  in ‘change missing values to No Data’→ 
click OK. The output raster would appear as displayed in Figure C-87.
 

Figure C-86 Reclassified SPI layer

Figure C-87 Output result of reclassified SPI layer
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Multi-criteria Decision Making Using the Analytic Hierarchy Process
MCDA-AHP based weightage assignment of flood conditioning factors: Within the various MCDA 
techniques present, the Analytical Hierarchy Process (AHP) is the most frequent and widely employed 
approach and has increasingly been used in determining flood risks and flood susceptibility mapping. 
Developed by T. L. Saaty in 1971-1975 (Saaty, 1987), the AHP is a systematic method that takes into 
account the subjective attributes of a complex problem involving multiple factors and decomposes it 
into a ‘simple and subjective evaluated sub-problem hierarchy’ (Gupta & Dixit, 2022; Lin et al., 2020). 
It is effective because it can address conflicting data and incorporate human/expert judgement. The AHP 
process includes selecting factors, organizing them hierarchically, determining their significance, 
combining priorities, and ensuring consistency. Saaty’s scale of 1 to 9 (Saaty, 1987; Saaty, 2008) is used 
to assign scores or ranks to each FCF in a pair-wise comparison matrix based on their relative influences 
on flood and relative importance as shown in Tables 2 and 3, respectively.

• The AHP calculations, including the construction of the pair-wise comparison matrix and the 
derivation of the weights and consistency, were conducted using a web-based AHP solution tool 
created by Goepel (2018, https://bpmsg.com/ahp/).

• Open AHP calculations using Link: https://bpmsg.com/ahp/. (Figure C-88). 

Figure C-88 AHP calculations portal

• Click On ‘AHP Priority Calculator’ using Link: https://bpmsg.com/ahp/ as shown in the highlighted 
box in Figure C-88.

• ‘Input number and names’ of layer insert number of layers ‘9’ click GO as shown in Figure C-89.
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Figure C-89 Input details for flood layer

• Window will appear ‘AHP Criteria Names’ insert name of layer (Insert all name of layer which we 
have prepared) → Click OK as displayed in Figure C-89.

Figure C-90 AHP Priority Calculator

• Window will appear having ‘AHP Priority Calculator’ as displayed in Figure C-90 insert priorities 
of layer based on Saaty (1980) scale where pairwise comparison of each layer and its importance is 
defined based on Saaty scale.
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• A pairwise comparison matrix of the indicators is created according to relative importance on a 
qualitative scale of 1 to 9 as shown in Table C-3. 

Table C-3: The relative importance of each criterion based in Saaty (1980)

Scales Numerical rating Reciprocal

Equally importance 1 1
Equally to moderately importance 2 1/2
Moderately importance 3 1/3
Moderately to strongly importance 4 1/4
Strongly importance 5 1/5
Strongly to very strongly importance 6 1/6
Very strongly importance 7 1/7
Very strongly to extremely importance 8 1/8
Extremely importance 9 1/9

• Start pairwise comparisons (Figure C-91) → Select the layer which is more important →  For 
example between slope and TWI, TWI is very strong important than select ‘7’, Slope and Distance 
to river if you feel they are equal important than select ‘1’. → Complete all pairwise comparison 
for all 36 layers→  click calculate.

Figure C-91 Pairwise comparisons of each layer and its importance

• Click Check Consistency to get the priorities. Acceptable results are achieved if the computed 
consistency ratio (CR) is below 10%, as visible in the highlighted boxes in Figure C-92.
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Figure C-92 Example of AHP calculation and its results

• Once the AHP based priority of each factor are obtained, the reclassified and weighted thematic 
layers are overlaid and combined using the ‘Weighted Overlay”.

• Preparing the Weighted Overlay: Open GIS platform, connect dataset folder, and add the reclassify 
layer for the AOI prepared in step ‘preparing the thematic layer’ (West Bengal state to the interface 
‘\Dataset\ Classified Results \’). 

• To Add data, click   → Add data Box will appear → click  to connect dataset folder →Select 
location to ‘\Dataset\’→ Click OK (Figure C-93).

Figure C-93 Connect dataset folder
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• To Add the Reclassify prepared thematic layer’ → Double click on Classified Results folder → 
Select all layers and Click ADD (Figure C-94).

Figure C-94 Adding the reclassified flood layer to GIS

• Weighted Overlay: In ArcToolbox, go to ‘Spatial Analysis Tools’ → Select the ‘Overlay’ → Select 
the ‘Weighted Overlay’ tool → In the ‘Weighted Overlay’ window, click + to ADD layers (Figure 
C-95). 

Figure C-95 Navigate to the weighted overlay tool and add layers
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• ‘Add Weighted Overlay Layers’ window will pop-up, select the layers one by one in ‘Input raster’ 
→ click OK → (Repeat and add all the layers by again clicking on ADD layers button) (Figure C-
96).

Figure C-96 Add weighted overlay layer to weighted overlay tool

• Once all the layers are added in the Weighted Overlay window insert the weight obtained by AHP 
(Figure C-97).

Figure C-97 Inserting weights obtained from AHP calculator for weighted overlay

• Select ‘Evaluation scale’ to ‘1 to 5 by 1’ → check all ‘Scale Value’ it should be 1 to 5 if not 
change it to 1 to 5 (Figure C-98) → In ‘Output Raster’ select relevant folder and assign file name 
(‘Dataset\Raster \Flood_map.tif‘) → click OK (Figure C-98).
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Figure C-98 Insert evaluation scale for weighted overlay

• Changing the colour scheme of Flood Map layer: Right click on ‘Flood Map layer’ layer in the 
‘Table of Contents’ section → Click on ‘Properties → A dialog box of ‘Layer Properties’ appear → 
Click on ‘Symbology’ → In ‘Unique values’ section, select a desired color palette in ‘Color Scheme’ 
→ Click OK (Figure C-99). 

Figure C-99 Assign a colour scheme to the reclassified flood layer
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Calculation of Flood Hazard

• Converting Raster to polygon: In ArcToolbox, go to Conversion Tools → select ‘from Raster’ → 
select ‘Raster to Polygon’ → Window will pop-up, select the Flood Map layer obtain in last step 
(‘Dataset\Raster\Flood_Map.tif’) in ‘Input raster’ → In ‘Output polygon features’ select relevant 
folder and assign file name (‘Dataset\Shapefile\FloodMap.shp’)→ click OK. (Figure C-100)

Figure C-100 Convert flood layer to shapefile

• Dissolve polygon feature of Flood Map: In Main Menu, go to Geoprocessing → select ‘Dissolve’ 
→ ‘’Window will pop-up, select the Flood Map layer obtain in last step 
(‘Dataset\Raster\Flood_Map.tif’) in ‘Input raster’ → In ‘Output polygon features’ select relevant 
folder and assign file name (‘Dataset\Shapefile\FloodMap_Dissolve.shp’)→ click OK. (Figure C-
101)
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Figure C-101 Dissolve polygon feature in the flood layer

• Extract High and Very High flood Area: In Table of contents, Right click on Dissolve Shapefile → 
select ‘Open Attribute Table’ → select ‘Gridcode’ column having value 4 and 5’ as shown in Figure 
C-102 below→ go to Table of contents, Right click on Dissolve Shapefile as shown in Figure C-
103→ → select ‘Data’→ select ‘Export Data’→ Select ‘Output features class’ select relevant folder 
and assign file name (‘Dataset\Shapefile\High_Class_flood.shp’)→ click save → click OK

Figure C-102 Select high and very high flood area for extraction
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Figure C-103 Export high and very high flood area to new shapefile

• Add Attribute for high class flood: In Table of contents, Right click on Dissolve Shapefile → select 

‘Open Attribute Table’ → In ‘Table’ window select  → select ‘Add Field’→ ‘Add Field’ 
window will pop-up → Insert the name of heading in table in ‘Name’ (for example Flood) → click 
OK the result ‘Table’ window will be as Figure  → Go to Main Menu, go to Geoprocessing → 
select ‘Dissolve’ → ‘’Window will pop-up, select the High class Flood Map layer obtain in last step 
(‘Dataset\Raster\High_Class_Flood’) in ‘Input Features’ → In ‘Output features class’ select 
relevant folder and assign file name (‘Dataset\Shapefile\FloodArea.shp’)→  select ‘Dissolve 
Field(s)’ check mark the added attribute in last step (‘Flood’) → click OK. (Figure C-104)

Figure C-104 Adding a field to the shapefile attribute table for high class flood
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• Dissolving Shapefile for High-Class Flood: In Table of contents, Right click on Dissolve Shapefile 

→ select ‘Open Attribute Table’ → In ‘Table’ window select  → select ‘Add Field’→ ‘Add 
Field’ window will pop-up show in Figure C-105→ Insert the name of heading in table in ‘Name’ 
(for example Flood) → click OK the result ‘Table’ window will be as Figure C-105

 

Figure C-105 Dissolving shapefile with high and very high flood classes into a single flood area

• Projecting district shapefile to UTM Coordinate system: In ArcToolbox, go to Data Management 
Tools → select ‘Projection and Transformations’ → select ‘Project’ → ‘Project’ window will pop-
up, select the AOI/State district file shapefile ‘Input Feature class’ (‘WB_district.shp’) →As show 

in Figure C-106 in ‘Output Coordinate System’ select  → ‘Spatial Reference Properties’ 
window will pop-up, select the ‘Projected Coordinate Systems’ → select the ‘UTM’ → select the 
‘Northen Hemisphere’ → select the ‘WGS 1984 UTM Zone 45N’ → click OK → In ‘Output feature 
class’ select relevant folder and assign file name (‘Dataset\Shapefile\WB_District_UTM.shp’)→ 
click OK. (Based on the UTM Zone where our AOI lies, select the corresponding UTM zone. To 
check your UTM zone here https://www.dmap.co.uk/utmworld.htm )
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Figure C-106 Projecting district shapefile to UTM Coordinate System

• Projecting to Dissolve Flood Area shapefile to UTM Coordinate system: In ArcToolbox, go to Data 
Management Tools → select ‘Projection and Transformations’ → select ‘Project’ → ‘Project’ 
window will pop-up, select the dissolve flood area shapefile obtained in last step in ‘Input Feature 

class’ (‘Flood_Area.shp’) →As show in Figure C-107 in ‘Output Coordinate System’ select  → 
‘Spatial Reference Properties’ window will pop-up, select the ‘Projected Coordinate Systems’ → 
select the ‘UTM’ → select the ‘Northen Hemisphere’ → select the ‘WGS 1984 UTM Zone 45N’ → 
click OK → In ‘Output feature class’ select relevant folder and assign file name 
(‘Dataset\Shapefile\Flood_Area_UTM45.shp’)→ click OK.
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Figure C-107 Projecting flood shapefile to UTM Coordinate System

• Linking district with flood area: In ArcToolbox, go to Analysis Tools → select ‘Overlay’ → select 
‘Intersect’ → ‘Intersect’ window will pop-up, select the projected AOI district shapefile and also 
the projected dissolved flood area output layer obtain in last step in ‘Input Feature’ as shown in 
Figure→ In ‘Output feature class’ select relevant folder and assign file name 
(‘Dataset\Shapefile\Flood_District_UTM45.shp’)→ click OK. (Figure C-108)

Figure C-108 Linking district with flood area
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• Calculate flood area: In Table of contents, Right click on Projected Shapefile 

(‘Flood_District_UTM45.shp’)→  select ‘Open Attribute Table’ → In ‘Table’ window select  
→ select ‘Add Field’→ ‘Add Field’ window will pop-up → Insert the name of heading in table in 
‘Name’ (for example Flood_Area) → select ‘Type’ as ‘Float’ →click OK →the result ‘Table’ 
window will be as Figure C-109  → go to the added field column name in ‘Table’ → Right click 
Column ‘Flood_Area’ ) → select ‘Field Calculator’ → ‘Calculate Geometry ’Window will pop-up, 
select the ‘Units’ as ‘sq km’ click OK.

Figure C-109 Calculate flood area

• Export Flood area to Excel: In Table of contents, Right click on calculated flood area shapefile in 
last step (‘Flood_District_UTM45.shp’)→  select ‘Open Attribute Table’ → In ‘Table’ window 

select  → select ‘Select All’→ Right click on row of the Table window click ‘Copy selected’ 
→ Open new excel sheet and paste (Figure C-110).
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Figure C-110 Export Flood area to Excel

• Calculate percentage flood area in Excel: In Excel add new column name percentage area use 
formula 100 x Flood Area / District area to calculate example shown below Figure C-111.

Figure C-111 Calculate percentage flood area in Excel

• This FHI value would then be combined with the normalized hazard-specific exposure and 
vulnerability indicator values to calculate the final Flood Risk Index (FRI) of each district 
within the state “WB”.
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Calculation of Hazard-specific Exposure Index 

Since all the indicators have positive relationship with exposure, i.e., a higher value of the indicator is 
associated with a higher level of exposure, the normalisation is based on Equation D-1. The Exposure 
Indices (EI) are calculated by taking a simple Arithmetic Mean of the normalised values after 
assigning equal weights to all the indicators. The values thus obtained suggest the relative exposure of 
the districts within a state to floods and drought.  

      𝑥𝑥��
� =  �������������

��������������  {���}
                          (Equation D-1) 

 

Where, 𝑥𝑥�� 
�  is the normalized value of thejth indicator of the ith district, 𝑋𝑋�� is the actual 

value,𝑀𝑀𝑀𝑀𝑀𝑀��𝑋𝑋��� is the maximum value, and 𝑀𝑀𝑀𝑀𝑀𝑀�{𝑋𝑋��} is the minimum value. 

Two exposure indicators have been considered for both hazards. For drought exposure, these 
indicators are “Population density and Proportion of area under rainfed agriculture”, whereas for flood 
exposure, they are “Population density and Percentage land under agricultural use”. 

● Example showing normalization for flood related indicators for District A1. 

Percentage of land under agricultural use: The maximum and minimum values as shown in 
Table D-1, are 86.65 (District V) and 24.45 (District J), respectively. So, the denominator is 
(Xmax – Xmin) = (86.65-24.45) = 62.20. [Note that the denominator will be identical for all 
districts under consideration]. 

The numerator for District A is (Xactual – Xmin) = (48.76-24.45) =24.31.  

Hence, the normalized value of the indicator population density for District D = 24.31/62.20 = 
0.39. 

Deploying the same formula, we will get the normalised value of all other indicators. The 
normalised values for overall districts will vary between 0 and 1, and are unit free. 

The Actual and Normalized values for the flood related indicators for all the districts are shown 
in Table D-1. 

Similarly, we can calculate the normalized values of each of the drought exposure indicators for 
each district.  

● Example showing normalization for drought related indicators for district A. 

Proportion of area under rainfed agriculture: The maximum and minimum values are 0.94 
(District J) and 0.01 (District V), respectively (Table D-2). So, the denominator is (Xmax – Xmin) = 
(0.94-0.01) = 0.93. [The denominator will be identical for all districts under consideration]. 

The numerator for District A is (Xactual – Xmin) = (0.74 - 0.01) = 0.73.  

Hence, the normalized value of the indicator population density for District A = 0.73/0.93 = 0.78. 

Deploying the same formula, we will get the normalised value of all other indicators as shown in 
Table D-2. 

                                                           
1District A is a hypothetical district and does not represent a real district in India. 
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● Aggregation of Indicators and Developing the Exposure Index: The normalized values can be 
aggregated to build the Exposure Index. If different weights are attached to different indicators, 
then a weighted average will be considered to calculate the exposure index (i.e., normalized 
values are to be multiplied by their respective weights and then added up). However, in this case, 
since equal weights are given, a simple arithmetic mean will do.  

Example showing calculation of Flood Exposure Index (FEI) for District A. 
FEI = (0.43+0.39)/2 = 0.68 

Example showing calculation Drought Exposure Index (DEI) for district A. 

DEI = (0.43+0.78)/2 = 0.61 

● Exposure Ranking: Once the EIs are calculated for all districts, a comparative ranking is 
carried out based on the index value. Higher the value of EI for a particular district, higher 
will be its exposure. These exposure rankings are usually presented in tabular form. Here, we 
have ranked the 14 hypothetical districts according to their EI based on the two indicators that 
we have considered. Actual values and Normalized values for the flood and drought related 
indicators for all the districts are shown in Tables D-1 and D-2, respectively. 



Pa
rt

 D
  

D
-4

 
 Ta

bl
e 

D
-1

: 
A

ct
ua

l 
va

lu
es

 (
A

V
s)

 a
nd

 N
or

m
al

iz
ed

 v
al

ue
s 

(N
V

s)
 o

f 
in

di
ca

to
rs

 a
nd

 F
lo

od
 E

xp
os

ur
e 

In
de

x 
 

 
Ta

bl
e 

D
-2

: 
A

ct
ua

l 
va

lu
es

 (
A

V
s)

 a
nd

 N
or

m
al

iz
ed

 v
al

ue
s 

(N
V

s)
 o

f 
in

di
ca

to
rs

 a
nd

 D
ro

ug
ht

 E
xp

os
ur

e 
In

de
x 

 

D
is

tr
ic

t*
 

Po
pu

la
tio

n 
de

ns
ity

 
%

 L
an

d 
un

de
r 

ag
ri

cu
ltu

ra
l u

se
 

FE
I 

R
an

k 

 

D
is

tr
ic

t*
 

Po
pu

la
tio

n 
de

ns
ity

 
Pr

op
or

tio
n 

of
 a

re
a 

un
de

r 
ra

in
fe

d 
ag

ri
cu

ltu
re

 
D

EI
 

R
an

k 

 
A

V
 

N
V

 (+
) 

A
V

 
N

V
 (+

) 
 

 
 

 
A

V
 

N
V

 (+
) 

A
V

 
N

V
 (+

) 
 

 
A

 
14

63
.1

6 
0.

43
 

48
.7

6 
0.

39
 

0.
41

 
17

 
 

A
 

14
63

.1
6 

0.
43

 
0.

74
 

0.
78

 
0.

61
 

5 
B

 
55

3.
58

 
0.

02
 

54
.0

2 
0.

48
 

0.
25

 
22

 
 

B
 

55
3.

58
 

0.
02

 
0.

2 
0.

20
 

0.
11

 
21

 
C

 
82

6.
97

 
0.

14
 

72
.5

7 
0.

77
 

0.
46

 
14

 
 

 C
 

82
6.

97
 

0.
14

 
0.

01
 

0.
00

 
0.

07
 

22
 

D
 

78
7.

25
 

0.
13

 
82

.7
1 

0.
94

 
0.

53
 

11
 

 
 D

 
78

7.
25

 
0.

13
 

0.
56

 
0.

59
 

0.
36

 
16

 
E

 
96

0.
53

 
0.

20
 

60
.3

6 
0.

58
 

0.
39

 
18

 
 

E
 

96
0.

53
 

0.
20

 
0.

94
 

1.
00

 
0.

60
 

6 
F 

27
39

.3
6 

1.
00

 
55

.7
7 

0.
50

 
0.

75
 

2 
 

F 
27

39
.3

6 
1.

00
 

0.
45

 
0.

47
 

0.
74

 
4 

G
 

18
21

.6
9 

0.
59

 
66

.8
2 

0.
68

 
0.

64
 

3 
 

G
 

18
21

.6
9 

0.
59

 
0.

28
 

0.
29

 
0.

44
 

12
 

H
 

11
96

.8
1 

0.
31

 
59

.8
2 

0.
57

 
0.

44
 

16
 

 
H

 
11

96
.8

1 
0.

31
 

0.
74

 
0.

78
 

0.
55

 
8 

I 
20

33
.5

3 
0.

68
 

54
.3

5 
0.

48
 

0.
58

 
8 

 
I 

20
33

.5
3 

0.
68

 
0.

85
 

0.
90

 
0.

79
 

2 
J 

17
99

.1
9 

0.
58

 
24

.4
5 

0.
00

 
0.

29
 

21
 

 
J 

17
99

.1
9 

0.
58

 
0.

94
 

1.
00

 
0.

79
 

3 
K

 
88

3.
49

 
0.

17
 

76
.7

3 
0.

84
 

0.
51

 
13

 
 

K
 

88
3.

49
 

0.
17

 
0.

68
 

0.
72

 
0.

45
 

11
 

L
 

12
16

.5
8 

0.
32

 
77

.7
5 

0.
86

 
0.

59
 

7 
 

L
 

12
16

.5
8 

0.
32

 
0.

52
 

0.
55

 
0.

43
 

13
 

M
 

14
52

.3
8 

0.
42

 
74

.1
4 

0.
80

 
0.

61
 

5 
 

M
 

14
52

.3
8 

0.
42

 
0.

49
 

0.
52

 
0.

47
 

10
 

N
 

13
96

.1
3 

0.
40

 
75

.5
7 

0.
82

 
0.

61
 

6 
 

N
 

13
96

.1
3 

0.
40

 
0.

25
 

0.
26

 
0.

33
 

17
 

O
 

26
26

.3
2 

0.
95

 
61

.8
8 

0.
60

 
0.

78
 

1 
 

O
 

26
26

.3
2 

0.
95

 
0.

23
 

0.
24

 
0.

59
 

7 
P 

27
39

.3
6 

1.
00

 
30

.1
8 

0.
09

 
0.

55
 

10
 

 
P 

27
39

.3
6 

1.
00

 
0.

85
 

0.
90

 
0.

95
 

1 
Q

 
10

03
.0

6 
0.

22
 

65
.6

8 
0.

66
 

0.
44

 
15

 
 

Q
 

10
03

.0
6 

0.
22

 
0.

27
 

0.
28

 
0.

25
 

18
 

R
 

94
8.

98
 

0.
20

 
76

.1
9 

0.
83

 
0.

52
 

12
 

 
R

 
94

8.
98

 
0.

20
 

0.
27

 
0.

28
 

0.
24

 
19

 
S 

13
68

.6
9 

0.
39

 
71

.8
7 

0.
76

 
0.

57
 

9 
 

S 
13

68
.6

9 
0.

39
 

0.
42

 
0.

44
 

0.
41

 
15

 
T

 
50

3.
61

 
0.

00
 

69
.4

8 
0.

72
 

0.
36

 
19

 
 

T
 

50
3.

61
 

0.
00

 
0.

78
 

0.
83

 
0.

41
 

14
 

U
 

11
48

.7
4 

0.
29

 
47

.5
4 

0.
37

 
0.

33
 

20
 

 
U

 
11

48
.7

4 
0.

29
 

0.
69

 
0.

73
 

0.
51

 
9 

V
 

10
57

.2
3 

0.
25

 
86

.6
5 

1.
00

 
0.

62
 

4 
 

V
 

10
57

.2
3 

0.
25

 
0.

01
 

0.
00

 
0.

12
 

20
 

*T
he

 li
ste

d 
di

str
ic

ts
 a

re
 h

yp
ot

he
tic

al
 c

as
es

 a
nd

 d
o 

no
t r

ep
re

se
nt

 a
ny

 re
al

 d
ist

ri
ct

 in
 In

di
a 

 
*T

he
 li

ste
d 

di
str

ic
ts

 a
re

 h
yp

ot
he

tic
al

 c
as

es
 a

nd
 d

o 
no

t r
ep

re
se

nt
 a

ny
 re

al
 d

ist
ri

ct
 in

 In
di

a 
 

PART E

STEP-BY-STEP PROCEDURE FOR CALCULATION OF
VULNERABILITY INDEX



PART E

STEP-BY-STEP PROCEDURE FOR CALCULATION OF
VULNERABILITY INDEX



Part E

Calculation of Hazard-specific Vulnerability Index

The IPCC AR5 (2014) emphasizes that reducing vulnerability and exposure to current climate
variability is a critical first step towards adapting to future climate change. Vulnerability, as an
internal property of a system, reflects its susceptibility to harm due to climate hazards. Assessing
vulnerability under the current climate helps identify the weaknesses of natural or socio-economic
systems, uncovering the underlying drivers of these weaknesses. Such assessments provide valuable
insights for devising strategies to address these vulnerabilities and adapt to the influencing drivers
effectively. While long-term objectives like mitigating climate hazards and minimizing exposure are
essential, governments and development agencies can achieve substantial short- to medium-term
progress by focusing on vulnerability reduction. This approach enables a pragmatic pathway to
enhance resilience and adaptive capacity, paving the way for robust responses to future climate
impacts. By addressing systemic weaknesses and reducing vulnerability in the near term, stakeholders
can build a strong foundation for sustainable, long-term climate adaptation strategies.

The concept of vulnerability could be operationalized in two ways:
● Starting point/contextual approach (O'Brien, Eriksen, Nygaard, &Schjolden, 2007):

Vulnerability is considered as a pre-existing condition in anticipation of a hazard.

● Endpoint/outcome approach (Kelly & Adger, 2000; O'Brien, Eriksen, Nygaard, & Schjolden,
2007): Vulnerability of a system is assessed before and after exposure to a hazard.

In this manual, our focus is on the flood and drought-specific starting point/contextual vulnerability of
states and districts in India.

This section presents the method of normalizing and calculating the hazard-specific vulnerability at
the district level based on the illustrative data for hypothetical districts given in Table E-1. It
represents the actual values of the indicators (AV), normalised values (NV) and the composite
vulnerability index for all districts. Similar to the calculation of EI, the Vulnerability Indices (VI) are
calculated by taking a simple Arithmetic Mean of the normalised values after assigning equal weights
to all the indicators. After that, all the districts are ranked based on their VIs.

However, the process of normalization differs according to the indicator’s functional relationship with
vulnerability.

● For positively related indicators, i.e., indicators representing ‘sensitivity’, where an increase in
the value of the indicator increases vulnerability, normalization is carried out using Equation E-1.

(Equation E-1)     𝑥𝑥
𝑖𝑖𝑖𝑖
𝑃𝑃 =  

𝑋𝑋𝑋𝑋𝑋𝑋𝑋𝑋𝑋𝑋𝑋𝑋𝑋𝑋
𝑖𝑖
{𝑋𝑋

𝑖𝑖𝑖𝑖
}

𝑀𝑀𝑀𝑀𝑀𝑀
𝑖𝑖

𝑋𝑋
𝑖𝑖𝑖𝑖{ }−𝑀𝑀𝑀𝑀𝑀𝑀

𝑖𝑖
{𝑋𝑋

𝑖𝑖𝑖𝑖
}

Where is the actual value of the jth indicator if the ith district, is the maximum value,𝑋𝑋
𝑖𝑖𝑖𝑖

𝑀𝑀𝑀𝑀𝑀𝑀
𝑖𝑖

𝑋𝑋
𝑖𝑖𝑖𝑖{ }

and is the minimum value.𝑀𝑀𝑀𝑀𝑀𝑀
𝑖𝑖
{𝑋𝑋

𝑖𝑖𝑖𝑖
}

Example of normalization of an indicator representing sensitivity:

Normalization of “Proportion of small and marginal landholdings” for District A:The proportion of
small and marginal landholdings is considered an indicator of sensitivity and is thus positively related

E-2
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to vulnerability. The maximum and minimum values are respectively 1.00 (District S) and 0.89
(District O), as shown in Table E-1. So, the denominator is (Xmax - Xmin) = (1.00-0.89) = 0.10.

[Note that the denominator will be the same for all districts under consideration].

The actual value of the indicator for District A is 0.98; therefore, the numerator will be (Xactual- Xmin) =
(0.98-0.89) = 0.09.

Hence, the normalized value of proportion of small and marginal landholdings indicator for this
district = 0.09/0.10 = 0.9

Similarly, we can calculate the normalized values of each of the positive indicators for each of the
districts by applying the same normalization method.

● For negatively related indicators, i.e., indicators representing ‘adaptive capacity’, where
vulnerability decreases with an increase in the value of the indicator, normalization is achieved
by using Equation E-2.

(Equation E-2)𝑥𝑥
𝑖𝑖𝑖𝑖
𝑁𝑁 =  

𝑀𝑀𝑀𝑀𝑀𝑀
𝑖𝑖

𝑋𝑋
𝑖𝑖𝑖𝑖{ }−𝑋𝑋𝑋𝑋𝑋𝑋

𝑀𝑀𝑀𝑀𝑀𝑀
𝑖𝑖

𝑋𝑋
𝑖𝑖𝑖𝑖{ }−𝑀𝑀𝑀𝑀𝑀𝑀

𝑖𝑖
  {𝑋𝑋

𝑖𝑖𝑖𝑖
}

Where is the actual value of the jth indicator of the ith district, is the maximum value,𝑋𝑋
𝑖𝑖𝑖𝑖

𝑀𝑀𝑀𝑀𝑀𝑀
𝑖𝑖

𝑋𝑋
𝑖𝑖𝑖𝑖{ }

and is the minimum value.𝑀𝑀𝑀𝑀𝑀𝑀
𝑖𝑖
  {𝑋𝑋

𝑖𝑖𝑖𝑖
}

Example of normalization of an indicator representing adaptive capacity:

Normalization of “Livestock to human ratio” for District A: The livestock to human ratio is
considered an adaptive capacity indicator and is negatively related to vulnerability. The maximum and
minimum values are 0.28 (District B) and 0.03 (District F), respectively as shown in Table E-1. So,
the denominator is (Xmax -Xmin) = (0.28 - 0.03) = 0.25. Once again, the denominator will remain
constant for all districts under consideration.

Accordingly, the numerator for District A is (Xmax - Xactual) = (0.28 - 0.21) = 0.07.

Hence, the normalized value of the livestock to human ratio indicator for this district = 0.07/0.25 =
0.28.

Similarly, we can calculate the normalized values for all negative indicators using the same
normalization method.

● Aggregation of Indicators and Developing the Vulnerability Index (VI): The normalized
indicators need to be aggregated to come up with the Vulnerability Index. If different weights are
attached to different indicators, then a weighted average will be taken to calculate the index (i.e.,
normalized values are to be multiplied by their respective weights and then added up). However,
in this case, since equal weights are given, a simple arithmetic mean will do.

Example showing calculation of Vulnerability Index (VI) for District A.

VI = (0.35+0.11+0.39+0.59+0.81+0.28+1.00+0.79+1.00+0.72)/10 = 0.60

Once VIs have been calculated for all the districts, a comparative ranking can be carried out
based on the index values similar to the exposure ranking.
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Calculation of Hazard-specific Vulnerability Index
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Example of normalization of an indicator representing sensitivity:

Normalization of “Proportion of small and marginal landholdings” for District A:The proportion of
small and marginal landholdings is considered an indicator of sensitivity and is thus positively related
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to vulnerability. The maximum and minimum values are respectively 1.00 (District S) and 0.89
(District O), as shown in Table E-1. So, the denominator is (Xmax - Xmin) = (1.00-0.89) = 0.10.
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Example of normalization of an indicator representing adaptive capacity:

Normalization of “Livestock to human ratio” for District A: The livestock to human ratio is
considered an adaptive capacity indicator and is negatively related to vulnerability. The maximum and
minimum values are 0.28 (District B) and 0.03 (District F), respectively as shown in Table E-1. So,
the denominator is (Xmax -Xmin) = (0.28 - 0.03) = 0.25. Once again, the denominator will remain
constant for all districts under consideration.

Accordingly, the numerator for District A is (Xmax - Xactual) = (0.28 - 0.21) = 0.07.

Hence, the normalized value of the livestock to human ratio indicator for this district = 0.07/0.25 =
0.28.

Similarly, we can calculate the normalized values for all negative indicators using the same
normalization method.

● Aggregation of Indicators and Developing the Vulnerability Index (VI): The normalized
indicators need to be aggregated to come up with the Vulnerability Index. If different weights are
attached to different indicators, then a weighted average will be taken to calculate the index (i.e.,
normalized values are to be multiplied by their respective weights and then added up). However,
in this case, since equal weights are given, a simple arithmetic mean will do.

Example showing calculation of Vulnerability Index (VI) for District A.

VI = (0.35+0.11+0.39+0.59+0.81+0.28+1.00+0.79+1.00+0.72)/10 = 0.60

Once VIs have been calculated for all the districts, a comparative ranking can be carried out
based on the index values similar to the exposure ranking.
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STEP-BY-STEP PROCEDURE FOR CALCULATION OF 
HAZARD-SPECIFIC RISK INDEX 

 

 

 

 

 

 

 

 

 

 

 

  



Part F 
 

F-2 
 

Calculation of Hazard-specific Risk Index  

The risk index for both drought and flood are calculated based on the geometric mean of the specific 
Hazard Index (HI), Exposure Index (EI), and Vulnerability Index (VI) given as:  

Risk Index = �(𝐻𝐻𝐻𝐻 ∗ 𝐸𝐸𝐸𝐸 ∗ 𝑉𝑉𝑉𝑉)�                    (Equation F-1) 

Use of geometric mean is the best way of calculating the average value of components when they are 
in ratios. Various important global indicators, such as the Human Development Index (UNDP, 2021) 
is calculated based on exactly the similar method of normalization and taking geometric mean. 

 Example showing calculation of Flood Risk Index (FRI) for a hypothetical district A from values 
given in Table F-1 

FRI =�(0.27 ∗ 0.41 ∗ 0.60)� = 0.41 

 Example showing calculation of Drought Risk Index (DRI) for district A from values given in 
Table F-2 

DRI =�(0.27 ∗ 0.41 ∗ 0.60)� = 0.45 

Similarly, we can calculate the risk index for all districts for both flood and drought as shown in 
Tables F-1 and F-2 and rank them according to their relative values. 

Table F-1: Flood Hazard, Exposure, Vulnerability, and 
Flood Risk Index  Table F-2: Drought Hazard, Exposure, Vulnerability 

and Drought Risk Index 
District FHI FEI VI FRI  District DHI DEI VI DRI 

A 0.27 0.41 0.60 0.41  A 0.25 0.61 0.60 0.45 
B 0.20 0.25 0.49 0.29  B 0.70 0.11 0.49 0.34 
C 0.49 0.46 0.58 0.51  C 0.49 0.07 0.58 0.27 
D 0.47 0.53 0.48 0.49  D 0.76 0.36 0.48 0.51 
E 0.20 0.39 0.48 0.34  E 0.67 0.60 0.48 0.58 
F 0.93 0.75 0.61 0.75  F 0.33 0.74 0.61 0.53 
G 0.69 0.64 0.52 0.61  G 0.63 0.44 0.52 0.52 
H 0.39 0.44 0.50 0.44  H 0.58 0.55 0.50 0.54 
I 0.18 0.58 0.62 0.40  I 0.75 0.79 0.62 0.72 
J 0.01 0.29 0.49 0.11  J 0.20 0.79 0.49 0.43 
K 0.77 0.51 0.59 0.61  K 0.57 0.45 0.59 0.53 
L 0.68 0.59 0.56 0.61  L 0.43 0.43 0.56 0.47 
M 0.96 0.61 0.57 0.69  M 0.85 0.47 0.57 0.61 
N 1.00 0.61 0.57 0.70  N 0.65 0.33 0.57 0.50 
O 0.89 0.78 0.37 0.64  O 0.01 0.59 0.37 0.13 
P 0.10 0.55 0.47 0.29  P 0.71 0.95 0.47 0.68 
Q 0.38 0.44 0.56 0.46  Q 0.58 0.25 0.56 0.44 
R 0.61 0.52 0.52 0.54  R 0.90 0.24 0.52 0.48 
S 0.82 0.57 0.55 0.64  S 0.57 0.41 0.55 0.51 
T 0.01 0.36 0.65 0.15  T 0.79 0.41 0.65 0.60 
U 0.77 0.33 0.44 0.48  U 0.49 0.51 0.44 0.48 
V 0.40 0.62 0.58 0.52  V 1.00 0.12 0.58 0.42 

 








